perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Kobes <ra...@theoryx5.uwinnipeg.ca>
Subject Re: Status of ActivePerl in CVS
Date Fri, 01 Sep 2000 18:31:38 GMT
On Fri, 1 Sep 2000, Gerald Richter wrote:

[ .. ]
>                   The problem is the following warning:
> epmain.c(325) : warning C4113: 'int (__cdecl *)(struct sv *,struct magic *)'
> differs in parameter lists from 'int (__cdecl *)(struct interpreter *,struct
> sv *,struct magic *)'
> 
> The reason lies in the line 55 and the following function defines in
> epmacro.h:
> 
> int EMBPERL_mgGet##name (pTHX_ SV * pSV, MAGIC * mg) \
> 
> For a threaded Perl 5.6.0 pTHX_  gets declared correct so that it takes the
> Perl context. For ActiveState this should be the same (see man perlguts at
> the end), but as the warning shows us, it isn't. To work correctly pTHX_
> must be defined as " struct interpreter * ". I guess there is some define
> that is missing, which would cause the right #if in perl.h where all this
> stuff is setup.
> 
> Maybe it would be enought to add a
> 
> #define pTHX_ struct interpreter *
> 
> at the top of epnames.h.
> 
> Hope this helps a little bit (I send a copy to dev@perl.apache.org, maybe
> somebody there has more ideas)

Hi Gerald,
    I'll try that tonight - thanks.

> P.S. You and Matt talked about a lot of objects that you had to add manualy.
> What exactly was neccessary to do? Maybe I have an idea how to fix this,
> because I had played a some time around when I made the first version of
> Embperl to compile on Win32.

For me, this had to do with some missing symbols in building
libapreq of a while ago (although as Matt mentioned, he didn't 
find this recently for libapreq, so things may have changed 
since I tried it). However, there are some missing in AxKit. 
These symbols don't appear in ApacheModulePerl.lib, as built 
by mod_perl, so what seems to be required is to link in the 
*.obj files of the mod_perl build individually. It does
seem a bit strange ... Did you initially find a similar
problem with Embperl?

best regards,
randy




Mime
View raw message