perl-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pires Claudio <CPI...@nec.com.ar>
Subject Problem with Apache::AuthCookieDBI
Date Sat, 02 Sep 2000 00:01:56 GMT
Hi everybody, it's me again... I have a problem using
Apache::AuthCookieDBI... I cannot launch Apache using this module. 
First I installed Apache::AuthCookie succesfuly in my RedHat 6.2 system, I
tried it and it worked fine... Now, I want to implement session management
and I want to use Apache::AuthCookieDBI. The fact is that when I compile the
module and run "make test" I get the following message:

PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 test.pl
1..1
Undefined subroutine &Apache::perl_hook called at
/usr/lib/perl5/site_perl/5.005/i386-linux/mod_perl.pm line 28.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.005/Apache/AuthCookie.pm line 3.
BEGIN failed--compilation aborted at blib/lib/Apache/AuthCookieDBI.pm line
36.
BEGIN failed--compilation aborted at test.pl line 11.
not ok 1
make: *** [test_dynamic] Error 255

I am beginer using mod_perl but I think I have all necessary modules. I have
installed the following ones:

MD5 v1.7, IniConf v0.95, CGI v2.70, DBI v1.02, DBD::Pg v0.93,
Apache::AuthCookieDBI v1.18, Apache::DBI v0.10, Digest::Perl::MD5 v1.2,
Digest::MD5 v2.11 and Date::Calc v4.3 

The system has perl-5.00503-10, apache-1.3.12-2 and mod_perl-1.21-10

Anyway, I installed the module and when I restarted Apache I got the
following message

Starting httpd: Syntax error on line 307 of /etc/httpd/conf/httpd.conf:
Can't locate object method "dir_config" via package "Apache::Server" at
usr/lib/perl5/site_perl/5.005/Apache/AuthCookieDBI.pm line 82.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.005/Apache/AuthCookieDBI.pm line 94.

I dont know what is happened... I followed all instructions for install the
module and configuration, and everything seems to be OK.

If I comment the line 
PerlModule Apache::AuthCookieDBI 
from the httpd.conf file Apache works... but when I try to access to any
protected page I get a message like the following one:

[Fri Sep  1 16:57:48 2000] [error] Can't locate authenticate.pm in @INC
(@INC contains: /usr/lib/perl5/5.00503/i386-linux /usr/lib/perl5/5.00503
/usr/lib/perl5/site_perl/5.005/i386-linux /usr/lib/perl5/site_perl/5.005 .
/etc/httpd//etc/httpd/lib/perl) at (eval 7) line 3.
Can't locate object method "authenticate" via package
"Apache::AuthCookieDBI".

And It's obvious, because the Module wasn't readed by Apache...
I don't know much about mod_perl and I dont know where to look to fix the
problem... It seems to be a syntax problem... No... I can beleive it... Im
sure I did something wrong...
Has anybody an idea? Could anybody give me a hand?

Thanks 

Claudio

Mime
View raw message