perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Chamas <j...@chamas.com>
Subject Re: Migrate existing Apache::ASP code from mod_perl to mod_fcgid?
Date Sat, 28 Dec 2013 00:04:17 GMT
Hi Warren!

I am happy to look at helping get Apache::ASP to work under a new environment 
but it does seem that there is some progress on getting mod_perl to work under 
Apache 2.4.  It sounds like some distros actually have this working and possibly 
built on the "httpd24 development branch of mod_perl"

http://www.gossamer-threads.com/lists/modperl/modperl/105641

The ETAs seems pretty weak on when you should expect this to be working.  Might 
be worth looking at that development branch and see what's possible there or 
what patches other distros are using?

Regards,

Josh


On 12/27/13 3:30 PM, Warren Young wrote:
> mod_perl no longer builds against Apache 2.4[1].  Consequently, the RHEL 7 beta
> doesn't include it[2].
>
> The claimed replacement is mod_fcgid, but as far as I can tell from the
> Apache::ASP CGI page[3] the standalone CGI mode seems to require plain Perl
> scripts, not intermixed HTML + ASP/Perl files.
>
> So, does this effectively kill Apache::ASP?  Is there another path forward, or
> should I be looking to migrate to some other framework? (Catalyst?)
>
>
>
> [1] http://www.apachelounge.com/viewtopic.php?p=25033
> [2] http://goo.gl/Vn2Sxy
> [3] http://apache-asp.org/cgi.html
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
> For additional commands, e-mail: asp-help@perl.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message