perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Koebrick, Andrew (MNIT)" <andrew.koebr...@state.mn.us>
Subject Problem with Apache::ASP under Apache 2.4
Date Tue, 09 Jul 2013 18:41:50 GMT
Howdy,

I am attempting to upgrade our web server to use Apache 2.4, and the Apache::ASP is failing
with this message:

Can't locate object method "remote_ip" via package "Apache2::Connection
" at /usr/local/share/perl5/Apache/ASP/StateManager.pm line 85.\n at /usr/local/share/perl5/Apache/ASP/StateManager.pm
line 85.\n\tApache::ASP::InitState('Ap
ache::ASP=HASH(0x7f8184d3dbe8)') called at /usr/local/share/perl5/Apache/ASP.pm line 421\n\tApache::ASP::new('Apache::ASP',
'Apache2::RequestRec=SCALAR(0x7f8
184d3d990)', '/home/httpd/html/error.html') called at /usr/local/share/perl5/Apache/ASP.pm
line 184\n\tApache::ASP::handler('Apache2::RequestRec=SCALAR(0x7f8
184d3d990)') called at -e line 0\n\teval {...} called at -e line 0\n

It looks like the Apache2::Connection API changed quite a bit in 2.4

Are there any thoughts of updating the Apache::ASP code?  I still have lots of pages using
the package and would love to keep using it.  Otherwise, I guess if this project is not active
I will start the unpleasant task of migrating off of it.

Thanks,

Andrew Koebrick


---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message