perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Skylos the Doggie <sky...@doglover.com>
Subject Disaster with a debian update
Date Thu, 01 Jan 2004 19:04:46 GMT
Well, I had one HECK of a problem this morning.  My main web server would
segfault when I tried to run it!

I tried to track down for a couple hours WHY this was happening, but could
only tell it was in the perl module code that it was doing it.  I was
beginning to tear my hair out.  strace would show a read of AutoLoader.pm,
then apache would segfault.  ltrace would show roughly the same thing.
I'm not much of a debugger, I couldn't figure how to get a clear
traceback.  :(  Such information would be handy if ya'll know it.

I finally resorted to telling my debian package manager to upgrade to the
unstable distribution versions of the relevant packages, and reinstalled
the stack of debian packages that run my sites to the very latest cutting
edge versions:

apache
apache-common
libapache-asp-perl
libapache-dbi-perl
libapache-mod-perl
libapache-mod-ssl
libapache-mod-ssl-doc

A little hoking around with config file patterns that changed and a demo
snake-oil ssl config out of the way., and it started to work.

But on the other hand, my other web server which varies primarily in the
fact it doesn't run ssl stuff, continued to operate absolutely fine with
the normal upgrade.

I don't know what to make of it really, I'm just glad that I finally got
it to work again.

Skylos

- skylos@doglover.com
- The best part about the internet is nobody knows you're a dog.
  (Peter Stiener, The New Yorker, July 5, 1993)
- Dogs like... TRUCKS!  (Nissan commercial, 1996)
- PGP key: http://dogpawz.com/skylos/mykey.asc

---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message