perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart Johnston <sjohns...@vaultranet.com>
Subject Re: Virtual host
Date Wed, 10 Dec 2003 16:29:16 GMT
I'm not sure about Mandrake 8.2 but Mandrake 9.x uses a somewhat 
non-standard Apache setup.  Mod_perl runs as a seperate process and is 
supposed to be proxied by the main Apache, if you have both installed.

On my Mandrake 9.1 machine, I can access Apache-ASP (installed from the 
RPM) only by going directly to the mod_perl server at port 8200.  Also, 
Mandrake uses several different config files and it can be hard to know 
what to put where.

I'm sorry if I am telling you things you already know but I would be 
happy to try and help you figure this out if I can.


Stuart Johnston


Shannon Doyle wrote:
 >
> Looking through the httpd-perl error log I get
> 
> [notice] Apache-AdvancedExtranetServer/1.3.23 (Mandrake Linux/4mdk)
> mod_perl/1.26 configured -- resuming normal operations
> 
> So it would seem that it is being loaded. 
> 
> OK now I am stumped.
> 
> BTW it doesn't load if I leave off the "<IfModule ..>"- condition
> 
> - Shannon
> 
> 
> -----Original Message-----
> From: Shannon Doyle [mailto:shannon@wyattgroup.com.au] 
> Sent: Wednesday, 10 December 2003 11:32 AM
> To: 'Helmut'; asp@perl.apache.org
> Subject: RE: Virtual host
> 
> Hi Helmut,
> 
> Hmm looking at the error log I ge the following
> 
> [notice] Apache-AdvancedExtranetServer/1.3.23 (Mandrake Linux/4mdk)
> mod_ssl/2.8.7 OpenSSL/0.9.6c PHP/4.1.2 configured -- resuming normal
> operations 
> 
> Which would suggest that mod_perl is not being loaded. I will take alook at
> that path and see whats going on
> 
> Incidentally, I am running Apache/ModPerl 1.3.23 
> 
> -----Original Message-----
> From: Helmut [mailto:h.zeilinger@envirotex.de]
> Sent: Tuesday, 9 December 2003 5:19 PM
> To: Shannon Doyle; asp@perl.apache.org
> Subject: Re: Virtual host
> 
> Hi Shannon,
> 
> your conf file seems to be ok.
> 
> Does/did it work when you leave the
> "<IfModule ..>"-condition and / or write "<Files ~ (.*)>"?
> 
> Is modperl loaded or compiled in? After server startup does the error log
> say something like:
> 
> [..]
> [notice] Apache/2.0.48 (Unix) mod_perl/1.99_10 Perl/v5.9.0 mod_ssl/2.0.48
> OpenSSL/0.9.6g configured -- resuming normal operations [..]
> 
> which indicates that modperl should have been loaded?
> 
> By the way - what Apache/ModPerl version are you using?
> 
> Helmut
> 
> 
> --On Tuesday, December 09, 2003 12:33:16 +1030 Shannon Doyle
> <shannon@wyattgroup.com.au> wrote:
> 
> 
>>Hi People,
>>
>>Just got Apache:ASP installed on my mandrake 8.2 standard install box 
>>and was wondering how I get this to parse .asp files correctly under a 
>>virtual host.
>>
>>Currently I have the following in the <virtualhost> tags along with 
>>the usual stuff for a virt host.
>>
>><IfModule mod_perl.c>
>>PerlModule Apache::ASP
>><Files ~ (\.asp)>
>>        SetHandler perl-script
>>        PerlHandler Apache::ASP
>>        PerlSetVar Global .
>>        PerlSetVar StateDir /tmp/asp
>></Files>
>></IfModule>
>>
>>While httpd starts ok, whenever a .asp file is called from a browser 
>>the file is displayed however it ignores all asp functions, ie 
>>included files etc.
>>
>>Any help would be appreciated.
>>
>>Cheers,
>>
>>
>>Shannon


---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message