pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From stefano bucci <stefanobu...@gmail.com>
Subject Re: Help debugging a pdf
Date Wed, 27 Jan 2016 16:46:19 GMT
Hi!
  Thank you for your quick answer.... unfortunately I'm not able to see the
image you attached :(
Anyway I tried preflight myself and I got some error messages like these

Some about fonts..

2.4.3 : Invalid Color space, The operator "f" can't be used without Color
Profile
2.4.3 : Invalid Color space, The operator "g" can't be used without Color
Profile
2.4.3 : Invalid Color space, The operator "f" can't be used without Color
Profile

3.1.1 : Invalid Font definition, Times-BoldItalic: some required fields are
missing from the Font dictionary: firstChar, lastChar, widths.
3.1.3 : Invalid Font definition, Times-BoldItalic: FontFile entry is
missing from FontDescriptor

These seems more severe... do you think this can be the MAIN problem?? I'm
investigatting on this!!

1.2.7 : Body Syntax error, Filter specified in metadata dictionnary

Thank you
Stefano


On Wed, Jan 27, 2016 at 12:39 PM, Roberto Nibali <rnibali@gmail.com> wrote:

> Hi
>
> When you run the preflight app inside the PDFBox sources, you get the
> following output:
>
> [image: Inline image 1]
>
> Maybe this already gives you some hints.
>
> Cheers
>
> Roberto
>
> On Wed, Jan 27, 2016 at 10:33 AM, stefano bucci <stefanobucci@gmail.com>
> wrote:
>
>> Hi all,
>>   I'm using a combination of FOP + pdf images plugin (
>> https://xmlgraphics.apache.org/fop/fop-pdf-images.html) + pdfbox to
>> produce
>> a press review merging together various pdfs + formatting.
>>
>> Usually it works fine, but I have problems with some files. It happens
>> that
>> when I try to import some of them (like this one
>> http://steuu.guru/original.pdf ) the output file is broken (
>> here:  http://steuu.guru/broken.pdf ) ...the REAL problem is that is
>> broken
>> ONLY when you open it with acrobat, all the other programs I used (foxit,
>> okular, and the browsers) can read it correctly. Acrobat tells me that
>> there is a problem opening the file, but it gives me no idea about what
>> the
>> problem is...
>>
>> I tried to open it with the pdfbox debugger (version 2 ) and it finds no
>> problem. Can you help me find a way to debug this file??
>>
>> Thank you
>> Stefano
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message