pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maruan Sahyoun <sahy...@fileaffairs.de>
Subject Re: Error on PDDocument.load
Date Wed, 21 Jan 2015 10:54:10 GMT
Hi Kevin

works for me - what's your Java Version?

BR
Maruan

Am 21.01.2015 um 11:24 schrieb Kevin Morin <morin@codelutin.com>:

> Hi,
> 
> it does not work with PDFToImage either, I still get a blank image. Plus, I did not set
the nonSeq option however it seems to be using the non sequential parser. And I have the following
traces:
> janv. 21, 2015 11:20:02 AM org.apache.pdfbox.pdfparser.NonSequentialPDFParser ch
> eckXrefOffsets
> GRAVE: Can't find the object 7 0 (origin offset 359138)
> janv. 21, 2015 11:20:03 AM org.apache.pdfbox.contentstream.PDFStreamEngine opera
> torException
> GRAVE: Missing XObject: Im1
> 
> BR
> 
> Kevin
> 
> On 21/01/2015 11:11, Maruan Sahyoun wrote:
>> Hi Kevin,
>> 
>> you can test with the PDFToImage command [1] available in from the pdfbox-app [2]
if the issue happens there. The source for PDFToImage is available in the tools section of
the SVN repo or online viewable [3].
>> 
>> BR
>> Maruan
>> 
>> [1] https://pdfbox.apache.org/1.8/commandline.html#pdfToImage
>> [2] https://repository.apache.org/content/groups/snapshots/org/apache/pdfbox/pdfbox-app/2.0.0-SNAPSHOT/
>> [3] http://svn.apache.org/viewvc/pdfbox/trunk/tools/src/main/java/org/apache/pdfbox/tools/PDFToImage.java?view=markup
>> 
>> Am 21.01.2015 um 11:00 schrieb Kevin Morin <morin@codelutin.com>:
>> 
>>> Hi Andreas,
>>> 
>>> I am using the latest snapshot available on the maven repository. And I am running
my app on Windows Server 2008 R2 Standard and it does not work (white page). Could send me
the code or a jar to test on this server to check if it does not come from my code?
>>> 
>>> BR
>>> 
>>> Kevin
>>> 
>>> On 19/01/2015 19:13, Andreas Lehmkuehler wrote:
>>>> Hi,
>>>> 
>>>> Am 19.01.2015 um 12:45 schrieb Kevin Morin:
>>>>> Actually, the issue is not only these traces. The real issue is that
I
>>>>> have a
>>>>> blank image when I try to render the document.
>>>> I've checked your PDF and everything renders fine. I've tried
>>>> SNAPSHOT-891 on linux (running java 1.8, 1.7  and 1.6) and the latest
>>>> SNAPSHOT-947 on win7 running java 1.7
>>>> 
>>>> Maybe your SNAPSHOT is outdated?
>>>> 
>>>> BR
>>>> Andreas Lehmkühler
>>>> 
>>>>> On 19/01/2015 12:39, Kevin Morin wrote:
>>>>>> Hi,
>>>>>> 
>>>>>> I am using the 2.0 snapshot version to images of pdfs, but on some
>>>>>> documents, I have the following error when I call PDDocument.load(file):
>>>>>> 2015/01/19 12:32:48 ERROR
>>>>>> (org.apache.pdfbox.pdfparser.NonSequentialPDFParser:1864) - Can't
find
>>>>>> the object 7 0 (origin offset 359138)
>>>>>> 2015/01/19 12:32:48 ERROR
>>>>>> (org.apache.pdfbox.contentstream.PDFStreamEngine:840) - Missing XObject:
>>>>>> Im1
>>>>>> 
>>>>>> I first had it a few days ago (I did not report it, shame on me)
but the
>>>>>> error did not occur when I called the loadLegacy method on PDDocument.
>>>>>> But the loadLegacy method is not available anymore...
>>>>>> 
>>>>>> The issue happens on Windows (works fine on Debian).
>>>>>> 
>>>>>> Thanks fo your help
>>>>>> 
>>>>>> Kevin
>>>>> 
>>>> 
>>> 
>> 
>> 
> 


Mime
View raw message