pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tilman Hausherr <THaush...@t-online.de>
Subject Re: Problems building the project
Date Sun, 18 Jan 2015 21:49:43 GMT
Hi,

Can't tell about the eclipse problems (I use netbeans), but re: strong 
encryption - could it be that you have several JDK versions on your system?

Another possible cause - I'm not 100% sure of this - is the question on 
whether to install it in the jre lib/security or in the jdk jre 
lib/security dir. It probably depends of what is used.

http://docs.oracle.com/cd/E19398-01/820-1228/agfik/index.html
"Where, <java-home> is the JRE directory within your Java Development 
Kit (JDK) environment, or the top-level directory of the JRE. "

Tilman

Am 18.01.2015 um 22:19 schrieb Stefan Falk:
> Hm, I don't get it. The requested files are already present on my 
> system. And I can even run the JUnit tests in Eclipse for the 
> encryption package successfully without any fails.
>
> It only fails if I run "mvn clean install" manually.
>
> I am rather concerned about these errors I am getting in Eclipse
>
> > Error(s) found in manifest configuration 
> (org.apache.felix:maven-bundle-plugin:2.4.0:bundle:default-bundle:package) 
> pom.xml
>
> and
>
> > Plugin execution not covered by lifecycle configuration: 
> org.codehaus.mojo:javacc-maven-plugin:2.6:javacc (execution: javacc, 
> phase: generate-sources)
> > Plugin execution not covered by lifecycle configuration: 
> com.googlecode.maven-download-plugin:maven-download-plugin:1.1.0:wget 
> (execution: get-isartor, phase: generate-test-resources)
>
> any ideas why I get these errors?
>
> Best regards,
> Stefan
>
>
>
>
>
> On 2015-01-18 21:08, Maruan Sahyoun wrote:
>> Hello Stefan,
>>
>> please find the dependencies listed here 
>> https://pdfbox.apache.org/2.0/dependencies.html. You're missing the 
>> "unlimited strength" cryptography
>>
>> BR
>> Maruan
>>
>> Am 18.01.2015 um 20:33 schrieb Stefan Falk <s.falk@student.tugraz.at>:
>>
>>> Hi!
>>>
>>> I really get quite a list of errors when I check out the trunk as 
>>> Maven project using Eclipse Luna and the latest m2e Maven plugin 
>>> (see screenshot).
>>>
>>> I am not sure if I am missing a plugin or if I am using somewhere 
>>> the wrong version of a plugin.
>>>
>>> I've tried to do it manually by calling "mvn clean install" but this 
>>> fails too (see maven.log).
>>>
>>> Any help would be appreciated! Thank you!
>>>
>>> Best regards,
>>> Stefan
>>> <maven.log>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message