pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Hewson <j...@jahewson.com>
Subject Re: Problems building the project
Date Mon, 19 Jan 2015 04:08:52 GMT
On 18 Jan 2015, at 13:19, Stefan Falk <s.falk@student.tugraz.at> wrote:
> 
> Hm, I don't get it. The requested files are already present on my system. And I can even
run the JUnit tests in Eclipse for the encryption package successfully without any fails.

Sounds like you have more than one JRE installed, try running the org.apache.pdfbox.util.TestRendering
test from Eclipse and see what it prints out, it should log your JDK and version, e.g.

JDK: Java(TM) SE Runtime Environment
Version: 1.8

The above version is what appears in your attached Maven log from the previous mail.

— John

> It only fails if I run "mvn clean install" manually.
> 
> I am rather concerned about these errors I am getting in Eclipse
> 
> > Error(s) found in manifest configuration (org.apache.felix:maven-bundle-plugin:2.4.0:bundle:default-bundle:package)
pom.xml

I’m not sure where this error is coming from, if it’s M2E then it’s not our problem.
If it’s Maven then we might want to look at updating the felix plugin. However, that plugin
is for creating OSGi bundles, so I doubt it’s the cause of your other build problem.

> and
> 
> > Plugin execution not covered by lifecycle configuration: org.codehaus.mojo:javacc-maven-plugin:2.6:javacc
(execution: javacc, phase: generate-sources)
> > Plugin execution not covered by lifecycle configuration: com.googlecode.maven-download-plugin:maven-download-plugin:1.1.0:wget
(execution: get-isartor, phase: generate-test-resources)
> 
> any ideas why I get these errors?

These errors are specific to M2E and its configuration and not related to the Maven build
itself.

> Best regards,
> Stefan
> 
> 
> 
> 
> 
> On 2015-01-18 21:08, Maruan Sahyoun wrote:
>> Hello Stefan,
>> 
>> please find the dependencies listed here https://pdfbox.apache.org/2.0/dependencies.html.
You're missing the "unlimited strength" cryptography
>> 
>> BR
>> Maruan
>> 
>> Am 18.01.2015 um 20:33 schrieb Stefan Falk <s.falk@student.tugraz.at>:
>> 
>>> Hi!
>>> 
>>> I really get quite a list of errors when I check out the trunk as Maven project
using Eclipse Luna and the latest m2e Maven plugin (see screenshot).
>>> 
>>> I am not sure if I am missing a plugin or if I am using somewhere the wrong version
of a plugin.
>>> 
>>> I've tried to do it manually by calling "mvn clean install" but this fails too
(see maven.log).
>>> 
>>> Any help would be appreciated! Thank you!
>>> 
>>> Best regards,
>>> Stefan
>>> <maven.log>
> 


Mime
View raw message