pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lorenzo Carnevale" <lorenzo.carnev...@afea.eu>
Subject Can't get the size right
Date Mon, 10 Nov 2014 18:32:47 GMT
Hello.
I am using PDFBox to silent print some PDF.
The file I am using for testing can be found here: https://drive.google.com/file/d/0B5aKlab3K43ZV2VLSVR3X2NhTXM/view?usp=sharing
I tried to use version 1.8.6 at first, but the PDF I tried to print wouldn’t render correctly
the Times New Roman font and replace it with Sans Serif.
(Did I do something wrong?)

So I switched to version 2.0 which , I read somewhere, fared better in that sense. And it
works.
I am pretty happy with the result, but the default settings print the page in a noticeably
“shrinked” size – which didn’t happen with 1.8.6.

For now I am using the “Scaling.ACTUAL_SIZE” option for the Printer constructor, but even
in this case the resulting print is slightly larger than the original.
I hope somebody could help, either telling me how to get the fonts right in 1.8.6  or the
size right in 2.0 : )

Thank you
           Lorenzo Carnevale

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message