pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jon Wu <...@wuservices.com>
Subject Re: Garbled / distorted fonts during PDF to image conversion on recent versions
Date Mon, 27 Jan 2014 18:47:04 GMT
Thanks Tilman. I opened https://issues.apache.org/jira/browse/PDFBOX-1868.

The original PDF is attached to there and should be attached to my original
post as well.

I mentioned in the but that the PDF has an embedded TrueType (CID) font
with Identity-H encoding and was written by iText and the issue isn't
limited to this specific font but it's most obvious here so it's a good
example.


On Sat, Jan 25, 2014 at 2:30 AM, Tilman Hausherr <THausherr@t-online.de>wrote:

> Jon,
>
> Please submit a bug report to JIRA
> https://issues.apache.org/jira/browse/PDFBOX
> and attach a PDF that has the problem, not just the image. The font should
> be embedded unless the font is included in all OS.
> I suspect this is a comeback of bug PDFBOX-1435. I wonder if your font is
> a TT font.
>
> If you can't attach the actual PDF, try to get the font and create a new
> PDF (e.g. from WORD or Open Office) that has only that one glyph in large
> size.
>
> Tilman
>
>
>  Hi,
>>
>> Can you help me figure out why some (especially recent) versions of PDFBox
>> aren't rendering text nicely?
>>
>> I'm running PDFBox in a web server environment to rasterize PDFs with text
>> in them. However, I've found that in recent versions, I end up getting
>> garbled text using the same code.
>>
>> Here you can see that this big cursive F has a weird break in it in the
>> middle and all the curves aren't smooth which is really obvious when you
>> compare this bad image (1.8.3) with the PDF or a good one (1.6.0).
>>
>> [image: Inline image 1]
>>
>> Here's what it's supposed to look like:
>>
>> [image: Inline image 2]
>>
>> What's weird is that I don't get the bad image when I use pdfbox-app.jar
>> on
>> the PDF - it's only with my code.
>>
>> Good versions:
>> 1.6.0 (I'm on this now)
>> 1.7.0-SNAPSHOT from approx 10/24/11
>> 1.8.0-20130225.201137-98
>>
>> Bad versions:
>> 1.7.1
>> 1.8.0-SNAPSHOT from approx 3/1/13
>> 1.8.3
>> and many others in between
>>
>> I ended up downgrading to 1.6.0 because I had some issues with
>> transparency
>> on some of the good snapshots that were working, but I think the
>> transparency issues are resolved on 1.8.3.
>>
>> Any idea what could cause this?
>>
>> Thanks!
>> Jon
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message