pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brendan Jurd <dire...@gmail.com>
Subject Re: Failure to render text
Date Sun, 13 Jan 2013 21:58:14 GMT
On 11 January 2013 17:44, Andreas Lehmkuehler <andreas@lehmi.de> wrote:
> First of all, please subscribe yourself to the mailing list [1] otherwise
> you won't get any answers in the future. Your're getting this one solely
> because I cc'ed you manually.
>

I have done so.

> Your attachments didn't make it due to some restrictions to the mailing
> list. But as moderator I had access and I ran some tests ...

Okay.  What is your preferred way for me to make files available to the list?

> Hmmm, it works fine for me using 1.7.1. Did you ever try to use the
> PDFReader provided by PDFBox. If it works maybe something with your code is
> wrong.

I just tried that.  PDFReader renders the black border, and the CUPS
logo graphic, but none of the text.  I used File -> Save as Image to
export the failed render.  You can view it at [1], and the original
PDF is at [2].

So, if it is working for you and not for me, I figure that the problem
has something to do with my operating environment.  This is Gentoo
Linux x86_64 with KDE.  I tried it on Windows Server 2008 64-bit, and
it worked fine there.  I then tried it on Ubuntu with GNOME and got
the same result as Gentoo/KDE.  Any ideas what could cause the same
pdfbox JAR to render text on some systems but not others?  Is it
having trouble acquiring fonts, perhaps?

Cheers,
BJ

[1] https://docs.google.com/file/d/0B1-kBA9pHgNYLWpoVnRVanhpVnM/edit
[2] https://docs.google.com/file/d/0B1-kBA9pHgNYQXJMZUxYTE5RaXM/edit

Mime
View raw message