pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Swanson <...@swansongrp.com>
Subject Truetype Font not Loading in 1.7.0
Date Tue, 03 Jul 2012 21:55:55 GMT
I was finally able to get this entered in JIRA as PDFBOX-1355. I was 
unable to post the bug using my Android phone, the JIRA webpages appear 
to only work on desktop browsers. During the summer months, I will have 
very spotty or poor internet connectivity, and the phone becomes the 
only way to perform email and browse.

Also I tried to send this message, but I think the email address was 
wrong. So this is a re-send (hope there is no duplication of messages).


The essence of the bug report is:

I have been using a particular TrueType font with
many previous versions of PDFBox. It loaded and worked fine
up to version 1.6.0. Now at level 1.7.0, I get a
NullPointerException when attempting to load this
TTF file:


Exception: java.lang.NullPointerException
java.lang.NullPointerException
     at 
org.apache.pdfbox.pdmodel.font.PDTrueTypeFont.loadDescriptorDictionary(PDTrueTypeFont.java:319)
     at 
org.apache.pdfbox.pdmodel.font.PDTrueTypeFont.loadTTF(PDTrueTypeFont.java:166)
     at 
org.apache.pdfbox.pdmodel.font.PDTrueTypeFont.loadTTF(PDTrueTypeFont.java:142)
     at 
org.apache.pdfbox.pdmodel.font.PDTrueTypeFont.loadTTF(PDTrueTypeFont.java:129)
     at test.<init>(test.java:23)
     at test.main(test.java:36)


My testcase (simply performing a loadTTF()) works with 1.6.0
of PDFBox. This font is certainly an oldie, but it does validate
using "Font Book" on my Mac. That program looks through a TrueType font,
checking all internal tables for correctness.

The JIRA bug report has  a copy of the .ttf file.

Thanks for your assistance,


Bob Swanson


Mime
View raw message