pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Orion Poplawski <or...@cora.nwra.com>
Subject Re: [ANNOUNCE] Apache PDFBox 1.7.0 released
Date Mon, 02 Jul 2012 23:21:47 GMT
On 06/19/2012 11:36 AM, Andreas Lehmkuehler wrote:
> Hi,
>
> sorry for the late answer, but I didn't found the time before...
>
> Am 04.06.2012 18:09, schrieb Orion Poplawski:
>> On 06/01/2012 10:33 AM, Andreas Lehmkuehler wrote:
>>> Am 31.05.2012 01:04, schrieb Orion Poplawski:
>>>> On 05/30/2012 04:58 PM, Orion Poplawski wrote:
>>>>> On 05/29/2012 10:18 AM, Andreas Lehmkuehler wrote:
>>>>>> The Apache PDFBox community is pleased to announce the release of
>>>>>> Apache PDFBox version 1.7.0. The release is available for download
at:
>>>>>
>>>>> Hmm, I'm not able to build it on Fedora 17 with openjdk 1.7.0.
>>>>>
>>>>> I see *lots* of these tracebacks.
>>>>>
>>>>> Works for Fedora 16 though with openjdk 1.6.0. There may be other
>>>>> differences
>>>>> as well. Anyone else try building with Java 7?
>>>>>
>>>>
>>>> I should note that I am able to build PDFBox 1.6.0 fine with openjdk
>>>> 1.7.0, so
>>>> this is a new problem with PDFBox 1.7.0.
>>> It worked for me on win 7. Did you use the same environment to build pdfbox
>>> 1.6.0 and 1.7.0?
>>>
>>>
>>> BR
>>> Andreas Lehmkühler
>>
>> Yes it's the same build environment. Any other debug information that would be
>> useful?
> I tried the same and it worked for me. I used a fresh installed fedora 17
> including all updates.
>
> Here are the version details
>
> [lehmi@endor ~]$ java -version
> java version "1.7.0_03-icedtea"
> OpenJDK Runtime Environment (fedora-2.2.1.fc17.8-x86_64)
> OpenJDK 64-Bit Server VM (build 23.0-b21, mixed mode)
>
> [lehmi@endor ~]$ mvn -version
> #/usr/lib/jvm/java
> Apache Maven 3.0.4 (rNON-CANONICAL_2012-05-14_12-35_mockbuild; 2012-05-14
> 14:35:26+0200)
> Maven home: /usr/share/maven
> Java version: 1.7.0_03-icedtea, vendor: Oracle Corporation
> Java home: /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "3.4.2-4.fc17.x86_64", arch: "amd64", family: "unix"
>
> [lehmi@endor ~]$ uname -a
> Linux endor 3.4.2-4.fc17.x86_64 #1 SMP Thu Jun 14 22:22:05 UTC 2012 x86_64
> x86_64 x86_64 GNU/Linux
>
>
> What versions are you using?
>
> BR
> Andreas Lehmkühler

The same, but I'm using mvn-rpmbuild in order to build the pdfbox rpm.  See 
the attached spec file.  Build with rpmbuild -ba pdfbox.spec.  This ensures 
that it is built against system versions of needed libraries.  There are some 
modifications that are needed to make this work as well.



-- 
Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder Office                  FAX: 303-415-9702
3380 Mitchell Lane                       orion@nwra.com
Boulder, CO 80301                   http://www.nwra.com



Mime
View raw message