pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Chojecki <i...@rayman2200.de>
Subject Re: Why org.bouncycastle.* packages were specified as mandatory in the manifest in the pdfbox-1.5.0.jar
Date Thu, 23 Jun 2011 12:52:55 GMT
Zitat von Miao Fan <miao.fan@gmail.com>:

> Hello,
Hi Miao,

> I downloaded pdfbox 1.4 and 1.5 recently, and found the manifest in the
> downloaded jars contains mandatory dependencies of org.bouncycastle.*
> plugins which should not. I have to modify wrapper it by removing them from
> manifest to use. I want to confirm if that's a bug and if yes, how to submit
> a bug against it?
Some functionality of the pdfbox need the BC. I would also prefer to  
remove this dependancy because BC is a heavy weight library and do not  
harmony with a small pdf library.

> B.T.W, adding org.bouncycastle.* plugins is not option for us now since it
> needs to get legal approval etc to get them in.
I found out that the PDF Encryption need the library. So only for  
encrypted pdf documents.

Maybe someone can rewrite the code of the *.pdmodel.encryption.* and  
use only the java cryptography extension (JCE)

> Thanks,
>
> Miao

Best regards
Thomas



Mime
View raw message