pdfbox-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Swanson <...@swansongrp.com>
Subject re: TTF Font Contains Bad /Widths
Date Thu, 10 Mar 2011 14:00:13 GMT
 >> Hello all,
 >>
 >> "The Font 'ArialMT' contains bad /Widths." (PDFBox 1.5)
 >>
 >> I get this error message in Adobe Reader when using the Arial TTF 
provided
 >> with Windows (XP). On the mailing list, I found the message below 
without an
 >> answer though.
 >>
 >> Has anybody found a solution for this in the meantime?
 >>
 >> Best Regards,
 >> Nat
 >>
 >> Subject:Adobe Reader Error When Using TrueType *Fonts*[image:
 >> permalink]<http://markmail.org/message/36j7togktn4vevym>
 >> From:Bob S.... (rd...@swansongrp.com)Date:Jul 7, 2010 2:29:05 pmList:*
 >> org.apache.pdfbox.users*
 >>
 >> I switched my project over to use TrueType *fonts*, and they do 
work. I'm
 >> using *the* "Arial" *fonts* that came with my Mac system.
 >>
 >> However, when Adobe Reader first brings up *the* resulting PDF file, it
 >> displays an error window indicating that "*The* *Font* 'Arial-BoldMT' *
 >> contains* *bad* /Widths".
 >>
 >> *The* *fonts* appear to display just fine.
 >>
 >> Any thoughts?

That was my request for information. I can reproduce the
problem with versions of PDFBox after 1.1.0. I tried
to view the files on my wife's Windows 7 machine, and
get the same warning errors in Adobe Reader, so at least
the Adobe Reader does not depend on being on a Mac. Your
message indicates that the TTF files from Windows
cause the same message to appear.

(No warning is thrown by the "Preview" program
on the Mac, and the file is unreadable on my
Kindle, not a big surprise.)

I have two PDF files I created using the canned version
of  "org.apache.pdfbox.examples.pdmodel.HelloWorldTTF"
that comes with the distribution. This process eliminated
any possibility that my own PDF-creation software
was causing the problem. I ran the same command line,
using the 1.1.0 and 1.4.0 JAR files (and some versions
in between).

The file from 1.1.0 reads just fine, but those created
by any JAR after 1.1.0 all cause the same warning error.
(I have not been able to download 1.5.0 yet, but your
experience points to the same issue).


Should this be submitted as a bug report?

Bob Swanson

Mime
View raw message