pdfbox-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Perini Nicola (Jira)" <j...@apache.org>
Subject [jira] [Issue Comment Deleted] (PDFBOX-4684) No glyph for multiple unicode in font ArialUnicodeMS
Date Wed, 13 Nov 2019 16:20:00 GMT

     [ https://issues.apache.org/jira/browse/PDFBOX-4684?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Perini Nicola updated PDFBOX-4684:
----------------------------------
    Comment: was deleted

(was: Thanks for the prompt response.

No, the issue is not a different font, but those Unicode are not present on any glyph list
files.

{{A question on my side, after removing  {{glyphlist_ext}} and the method {{addGlyphs}} on {{GlyphList
, which should be the proper metod to add unicode character? }}}}

{{{{I cannot find any mention in the documentation}}}}

Could you share with me eventually  the code?

 )

> No glyph for multiple unicode in font ArialUnicodeMS
> ----------------------------------------------------
>
>                 Key: PDFBOX-4684
>                 URL: https://issues.apache.org/jira/browse/PDFBOX-4684
>             Project: PDFBox
>          Issue Type: Bug
>          Components: FontBox
>    Affects Versions: 2.0.17
>            Reporter: Perini Nicola
>            Priority: Major
>
> I'm encountering the same error issue reported in
> https://issues.apache.org/jira/browse/PDFBOX-3437
> for the following Unicode :
> U+4E8B  U+9EC4 U+50B2 U+610F U+FF0C U+8D64 U+81F3 (...)
> It seems to be a real issue considering that glyphs are present in the font and it's
the library that cannot detect properly.
> I've also tried with the 3.0.0.snapshot but the result is the same.
> The conversion works properly with other pdf libraries.
> May you suggest a workaround?
> Cheers
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@pdfbox.apache.org
For additional commands, e-mail: dev-help@pdfbox.apache.org


Mime
View raw message