pdfbox-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tilman Hausherr (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (PDFBOX-4454) PDFmergerUtility is changing the names of form fields to dummyField#X when fields have the same name.
Date Sat, 02 Feb 2019 18:33:00 GMT

     [ https://issues.apache.org/jira/browse/PDFBOX-4454?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tilman Hausherr closed PDFBOX-4454.
-----------------------------------
    Resolution: Duplicate

Ok, closing as duplicate. I've added you as a watcher there. That issue was opened 3 years
ago… this indicates it won't be fixed soon.

What I was thinking about is a tailored solution as a first step, not part of the repository
but kept here. Which would only work if it's very simple fields (only text) with few properties.

> PDFmergerUtility is changing the names of form fields to dummyField#X when fields have
the same name.
> -----------------------------------------------------------------------------------------------------
>
>                 Key: PDFBOX-4454
>                 URL: https://issues.apache.org/jira/browse/PDFBOX-4454
>             Project: PDFBox
>          Issue Type: New Feature
>          Components: AcroForm
>    Affects Versions: 2.0.13
>            Reporter: Seth Freeman
>            Priority: Critical
>              Labels: PDFMergerUtility
>
>  
> The merger renaming form fields that have the same name is a feature that should be optional.
In my situation, I need all the fields to keep their pre-merge names.
> In my case, we are using 3 different medical forms that intentionally all have fields
with the same name. In Acrobat merging would set the fields output equal to each other. I'm
working on a project to automate filling these forms with information provided by the patient.
Right now merging with PDFbox breaks this.
> My current workaround is to just fill each form separately then combine them, but this
makes edits later down the line needlessly complex. 
> The simplest solution would be to have options to maintain the names.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@pdfbox.apache.org
For additional commands, e-mail: dev-help@pdfbox.apache.org


Mime
View raw message