pdfbox-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tilman Hausherr (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (PDFBOX-4329) JPEG2000 abnormality
Date Tue, 02 Oct 2018 16:54:00 GMT

    [ https://issues.apache.org/jira/browse/PDFBOX-4329?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16635809#comment-16635809
] 

Tilman Hausherr commented on PDFBOX-4329:
-----------------------------------------

Something is weird with your project, why do you have both 2.0.11 and 2.0.12 ? 2.0.12 is unreleased.

I don't have any experience with shaded jars. What I use in my projects is this

{code:xml}
             <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-jar-plugin</artifactId>
                <version>3.1.0</version>
                <configuration>
                    <archive>
                        <manifest>
                            <addClasspath>true</addClasspath> 
                            <classpathPrefix>lib</classpathPrefix>
                            <mainClass>XXXXX</mainClass>
                        </manifest>
                    </archive>
                </configuration>
            </plugin>
            
            
            <plugin> 
                <artifactId>maven-dependency-plugin</artifactId> 
                <executions> 
                    <execution> 
                        <phase>install</phase> 
                        <goals> 
                            <goal>copy-dependencies</goal> 
                        </goals> 
                        <configuration> 
                            <outputDirectory>${project.build.directory}/lib</outputDirectory>

                        </configuration> 
                    </execution> 
                </executions> 
            </plugin> {code}
All jars are copied in the lib subdirectory.


> JPEG2000 abnormality
> --------------------
>
>                 Key: PDFBOX-4329
>                 URL: https://issues.apache.org/jira/browse/PDFBOX-4329
>             Project: PDFBox
>          Issue Type: Bug
>          Components: Utilities
>    Affects Versions: 2.0.11
>            Reporter: Evangelos Kogchylakis
>            Priority: Minor
>              Labels: how-to
>
> Hello,
> I am using a maven project with 2.0.11 dependency on pdfbox and:
> <dependency>
>  <groupId>com.github.jai-imageio</groupId>
>  <artifactId>jai-imageio-core</artifactId>
>  <version>1.4.0</version>
> </dependency>
> <dependency>
>  <groupId>com.github.jai-imageio</groupId>
>  <artifactId>jai-imageio-jpeg2000</artifactId>
>  <version>1.3.0</version>
> </dependency>
>  
> on pom.xml . When I run UnitTests on pdf to image conversion on jpeg2000 images they
work fine. When I run runtime conversions I get:
> SEVERE: Cannot read JPEG2000 image: Java Advanced Imaging (JAI) Image I/O Tools are not
installed
> Oct 02, 2018 7:07:08 PM org.apache.pdfbox.contentstream.PDFStreamEngine operatorException
> SEVERE: Cannot read JPEG2000 image: Java Advanced Imaging (JAI) Image I/O Tools are not
installed
> I am aware that the dependencies on the parent pom have only the "test" scope. 
> How can I fix this so that I dont get these 
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@pdfbox.apache.org
For additional commands, e-mail: dev-help@pdfbox.apache.org


Mime
View raw message