pdfbox-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Lehmkühler (JIRA) <j...@apache.org>
Subject [jira] [Commented] (PDFBOX-62) Incorrect (zero) character widths returned in some docs
Date Thu, 05 Jun 2014 21:02:02 GMT

    [ https://issues.apache.org/jira/browse/PDFBOX-62?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14019273#comment-14019273
] 

Andreas Lehmkühler commented on PDFBOX-62:
------------------------------------------

The missing width values are now extracted from the true type font directly. I've added the
changes in revision http://svn.apache.org/r1600761 to the trunk.
I'm going to merge the changes to the 1.8 branch soon.

> Incorrect (zero) character widths returned in some docs
> -------------------------------------------------------
>
>                 Key: PDFBOX-62
>                 URL: https://issues.apache.org/jira/browse/PDFBOX-62
>             Project: PDFBox
>          Issue Type: Bug
>          Components: Rendering, Text extraction
>    Affects Versions: 1.8.5, 2.0.0
>            Assignee: Andreas Lehmkühler
>             Fix For: 2.0.0
>
>         Attachments: 5542.pdf, PDFBOX-2059_PDTrueTypeFont.diff, PDTrueTypeFont.diff,
pdfbox-2006-zerowidth.pdf-1.png, pdfbox-62-zerowidth.pdf-1.png
>
>
> [imported from SourceForge]
> http://sourceforge.net/tracker/index.php?group_id=78314&atid=552832&aid=1216674
> Originally submitted by tamirhassan on 2005-06-07 13:42.
> For certain PDF documents (such as the one attached) 
> the character/string widths (as obtained e.g. by the 
> PDFont.getStringWidth method) are not returned 
> correctly, i.e. they appear to be correct for punctuation 
> characters but are zero for alphanumeric characters.  
> It seems as if these alphanumeric characters are NOT 
> within PDFont.firstChar and PDFont.lastChar in the 
> Type 1 font.  The method therefore attempts to obtain 
> the font widths from the AFM (font metric) file, but fails 
> (silently) with a 'resource is null' logline message.
> (Note that this problem doesn't seem to occur with Type 
> 1 fonts in other documents.)
> A more detailed discussion regarding this issue can be 
> found in this link:
> http://sourceforge.net/forum/forum.php?
> thread_id=1260349&forum_id=267205
> Thanks in advance for any help that can be obtained,
> Tam



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message