orc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Philipp Blum (JIRA)" <j...@apache.org>
Subject [jira] [Created] (ORC-169) Rename VectorizedRowBatch.size to rowCount
Date Mon, 10 Apr 2017 16:18:41 GMT
Philipp Blum created ORC-169:

             Summary: Rename VectorizedRowBatch.size to rowCount
                 Key: ORC-169
                 URL: https://issues.apache.org/jira/browse/ORC-169
             Project: ORC
          Issue Type: Improvement
            Reporter: Philipp Blum
            Priority: Minor

The property name size is a bit confusing because it's only a rowCount. A map or array element
also increase the size of a batch but will not be counted in size. So, you need an additional
counter to count the size of your current batch. I also think another property with the name
size or elementCount is a nice to have.

Please correct me, if I don't understand the concept. You can also take a look into the scala
library I wrote: https://github.com/Citrullin/scalaOrcWriter

This message was sent by Atlassian JIRA

View raw message