orc-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wgtmac <...@git.apache.org>
Subject [GitHub] orc pull request #113: ORC-176: Refactor common classes for writer and reade...
Date Fri, 28 Apr 2017 05:29:15 GMT
Github user wgtmac commented on a diff in the pull request:

    --- Diff: c++/include/orc/Statistics.hh ---
    @@ -37,12 +37,76 @@ namespace orc {
          * of rows because of NULL values and repeated values.
          * @return the number of values
    -    virtual uint64_t getNumberOfValues() const = 0;
    +    virtual uint64_t getNumberOfValues() const {
    +      return valueCount;
    +    }
    +    /**
    +     * Set the number of values in this column
    +     * @param newValueCount new number of values to be set
    +     */
    +    virtual void setNumberOfValues(uint64_t newValueCount) {
    --- End diff --
    If we put this into Impl classes, then there are many duplicate code which is not elegant.
So we decided to lift them up to the base classes so that duplicate codes are reduced significantly
while we were implementing the writer. What do you think?

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.

View raw message