openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Lambertus <...@apache.org>
Subject Re: website build broken
Date Tue, 09 Jul 2019 18:56:52 GMT
I’ve added the npm package to the puppet config, it should get automatically installed in
~30 minutes or so.



> On Jul 9, 2019, at 11:52 AM, Matt Rutkowski <mrutkows@us.ibm.com> wrote:
> 
> Apache build team,
> 
> It appears that recently that our Jenkins jobs for building and publishing 
> our project website for OpenWhisk has been failing (master) since mid-June 
> (on "websites" node).  The absence of the npm utility (plug-in) seems to 
> be the culprit and was available to us w/o issue until around that time 
> (in our groovy script) and a necessary part of building our static site 
> from Jekyll. 
> 
> Can npm be added back?
> 
> Thanks,
> Matt
> 
> ----- Forwarded by Matt Rutkowski/Austin/IBM on 07/09/2019 01:46 PM -----
> 
> From:   "David P Grove" <groved@us.ibm.com>
> To:     "OpenWhisk Dev" <dev@openwhisk.apache.org>
> Date:   07/09/2019 08:10 AM
> Subject:        [EXTERNAL] website build broken
> 
> 
> 
> 
> The Jenkins job to rebuild the openwhisk website on commits to
> incubator-openwhisk-website is broken (succeeded on 6/14, next build on 
> 7/3
> failed as did a build today).
> 
> It looks like a change in the Jenkins build environment.  The script is 
> not
> able to find npm [1].  Did we break this when attempting to do the other
> updates to our worker nodes?
> 
> + npm install
> /home/jenkins/jenkins-slave/workspace/OpenWhisk-website@tmp/durable-c5656c4f/script.sh:
> line 16: npm: command not found
> 
> 
> [1]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__builds.apache.org_view_O_view_OpenWhisk_job_OpenWhisk-2Dwebsite_237_console&d=DwIFAg&c=jf_iaSHvJObTbx-siA1ZOg&r=6zQLM7Gc0Sv1iwayKOKa4_SFxRIxS478q2gZlAJj4Zw&m=ZKLz58mIn2zpsvWZbrrzeSIdKrAZ0G-jmlP0PUpB3Q4&s=eyw9S7AgkN_zJhPf5ynyHAs2J5FMpvGqa3ndNeH6Y3A&e=

> 
> 
> 
> 


Mime
View raw message