openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Grove <dgr...@apache.org>
Subject Re: [DISCUSS] - prepare to release OpenWhisk catalog
Date Fri, 28 Jun 2019 21:23:04 GMT


On 2019/06/17 13:07:33, Rodric Rabbah <rodric@gmail.com> wrote: 
> If the weather package is functional and can run with newer node kinds then I’d favor
keeping it.

I verified weather is functional with nodejs:10.  Have a PR pending to update the documentation.
 Will merge as soon as the current travis problems induced by the standalone merge to the
core repo gets cleared up. 

> I’d favor removing the combinators as we have composer now and we didn’t document
them properly 

Done.

> I would consider removing the bash installers since they’re redundant with the wsk
deploy manifest.

Unfortunately there is a bug in client-go which causes wskdeploy to crash when apihost is
a host:port pair without a scheme prefix [1]. We can either (a) wait out a release cycle of
clientgo/cli/wskdeploy to get a fixed cli or (b) leave the bash installers in for this release
and cleanup after the next cli release.

> I’m indifferent on version number. 

me too.  Will probably default to 0.10.0. 

--dave

[1] https://github.com/apache/incubator-openwhisk-wskdeploy/issues/1050

Mime
View raw message