openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodric Rabbah <rod...@gmail.com>
Subject Re: Move default Node.js runtime to v10?
Date Fri, 19 Apr 2019 19:03:05 GMT
This is the catalog actions related issue that I opened at the time I
tried: https://github.com/apache/incubator-openwhisk-catalog/issues/294

Some of the actions which require packages available in the node6 runtime
fail in the newer node10 because we don't bundle any packages. So those
actions have to "zip" up their dependencies. The patch that was made was to
pin the catalog actions to node6 with the project deploy configuration. So
my assessment is that we can flip the default once again and should be OK
this time... but the catalog actions that are pinned to node6 will need to
be updated in a second phase.

-r



On Thu, Apr 18, 2019 at 12:52 PM James Thomas <jthomas.uk@gmail.com> wrote:

> On Wednesday's community call I asked about moving the default Nodejs
> version in the project to v10.
>
> Node.js 6 (which is the current default version) reaches  "end of life" on
> April 30th according to https://github.com/nodejs/Release. Node.js 10 is
> the current LTS version and is supported until April 2021.
>
> Rodric mentioned this was started previously but ran into issues with the
> providers?
> https://github.com/apache/incubator-openwhisk/issues/4265
>
> Does anyone have any issues with going forward with this work (once any
> issues have been resolved)? I see there is some work going on to fix the
> failures (https://github.com/apache/incubator-openwhisk/pull/4450)
>
> --
> Regards,
> James Thomas
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message