openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David P Grove" <gro...@us.ibm.com>
Subject Re: build issue - Cannot recognize package: gopkg.in/yaml.v2
Date Fri, 11 Jan 2019 23:16:29 GMT

I'm not an expert on the cli (or go project structure in general).  But I
did see the same error as you with `./gradlew compile -PnativeCompile`.  I
then did `./gradlew compile`, which succeeded and then `./gradlew compile
-PnativeCompile`. also worked.

I don't know if this is a stable behavior, but maybe try the longer build
which does the exhaustive mutli-platform compile first.  Somehow that seems
to resolve the dependency problem (at least for me, at least for now).

Maybe this is a quirk introduced by the merging in of wskdeploy.

--dave




From:	Matt Ryan <mattryan@apache.org>
To:	dev@openwhisk.apache.org
Date:	01/11/2019 04:45 PM
Subject:	build issue - Cannot recognize package: gopkg.in/yaml.v2



Hi,

I cloned the latest version of 'incubator-openwhisk-cli' and tried to
build, following the instructions in the README.md.  When I run './gradlew
compile -PnativeCompile' I get an error:

Cannot recognize package: gopkg.in/yaml.v2

I tried running 'go get gopkg.in/yaml.v2' which seemed to succeed but I'm
still getting the same error.

Any suggestions?


-MR



Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message