openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michele Sciabarra <mich...@sciabarra.com>
Subject Re: build issue - Cannot recognize package: gopkg.in/yaml.v2
Date Sat, 12 Jan 2019 06:02:25 GMT
In theory gopkg.in shoukd provide a ‘stable’ link for go packages. No
ever I had similar isse in the go proxy where a package hosted there
broke for no apparent reasons introducing segfaults, so I ended up
gettind rid of it alotogether.
--
  Michele Sciabarra
  michele@sciabarra.com



----- Original message -----
From: David P Grove <groved@us.ibm.com>
To: dev@openwhisk.apache.org
Subject: Re: build issue - Cannot recognize package: gopkg.in/yaml.v2
Date: Fri, 11 Jan 2019 18:16:29 -0500

I'm not an expert on the cli (or go project structure in general).  But
I did see the same error as you with `./gradlew compile -
PnativeCompile`.  I then did `./gradlew compile`, which succeeded and
then `./gradlew compile -PnativeCompile`. also worked.
I don't know if this is a stable behavior, but maybe try the longer
build which does the exhaustive mutli-platform compile first.  Somehow
that seems to resolve the dependency problem (at least for me, at
least for now).
Maybe this is a quirk introduced by the merging in of wskdeploy.

--dave


Inactive hide details for Mat…Matt Ryan ---01/11/2019 04:45:31 PM---Hi,
I cloned the latest version of 'incubator-openwhisk-cli' and tried to
From: Matt Ryan <mattryan@apache.org>
To: dev@openwhisk.apache.org
Date: 01/11/2019 04:45 PM
Subject: build issue - Cannot recognize package: gopkg.in/yaml.v2





Hi,

I cloned the latest version of 'incubator-openwhisk-cli' and tried to
build, following the instructions in the README.md.  When I run
'./gradlew compile -PnativeCompile' I get an error:

Cannot recognize package: gopkg.in/yaml.v2

I tried running 'go get gopkg.in/yaml.v2' which seemed to succeed but
I'm still getting the same error.

Any suggestions?


-MR






Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message