openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent S Hou" <s...@us.ibm.com>
Subject Re: [DISCUSS] Release Apache OpenWhisk 0.9.0-incubating: main OpenWhisk module
Date Fri, 29 Jun 2018 15:28:42 GMT
Hi Rodric,

I think all the issues can be resolved by updating the instruction of installation. 

I can definitely work on that.

Our vote for main OpenWhisk module is effective. After consolidating the result and fixing
the document, we should proceed with the release.
 
I have tried the local deployment, which turned out to be fine. I have documented some known
issues in the instruction.



Best wishes.
Vincent Hou (侯胜博)

Advisory Software Engineer, OpenWhisk Contributor, Open Technology, IBM Cloud

Notes ID: Vincent S Hou/Raleigh/IBM, E-mail: shou@us.ibm.com,
Phone: +1(919)254-7182
Address: 4205 S Miami Blvd (Cornwallis Drive), Durham, NC 27703, United States

-----Rodric Rabbah <rodric@gmail.com> wrote: -----
To: dev@openwhisk.apache.org
From: Rodric Rabbah <rodric@gmail.com>
Date: 06/29/2018 08:38AM
Subject: [DISCUSS] Release Apache OpenWhisk 0.9.0-incubating: main OpenWhisk module

I am breaking this out into a DISCUSS thread so not to pollute the vote. In
completing this checking list:

[x] Download links are valid.
[x] Checksums and PGP signatures are valid.
[x] Source code artifacts have correct names matching the current release.
[x] LICENSE and NOTICE files are correct for each OpenWhisk repo.
[x] All files have license headers if necessary. (checked with scan-code)
[x] No compiled archives bundled in source archive (modulo
gradle-wrapper.jar).

I ran into a few hiccups (some duplicates with Bertrand's) for which I
opened the following issues:

https://github.com/apache/incubator-openwhisk-release/issues/207
https://github.com/apache/incubator-openwhisk-release/issues/208
https://github.com/apache/incubator-openwhisk-release/issues/209 (bug)
https://github.com/apache/incubator-openwhisk-release/issues/210
https://github.com/apache/incubator-openwhisk-release/issues/211 (bug)
https://github.com/apache/incubator-openwhisk-release/issues/212
https://github.com/apache/incubator-openwhisk-release/issues/213 (bug,
blocks deployment)
https://github.com/apache/incubator-openwhisk-release/issues/214

Carlos I'm not sure how you deployed successfully and ran hello world. I'd
like to know if this is isolated to me. It looks like both Betrand and I
ran into issues with deployment (beyond the doc bug).

-r


Mime
View raw message