openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kumar Subramanian <kumarsubr...@vmware.com>
Subject Re: Error when deploying Whisk-Controller in dcos
Date Fri, 02 Mar 2018 23:20:44 GMT
Is that change at https://github.com/chetanmeh/incubator-openwhisk/blob/fa302249f4f9b4e6b3084956f18bda987674f46f/core/controller/Dockerfile
not merged? I don’t see change in master https://github.com/apache/incubator-openwhisk/blob/master/core/controller/Dockerfile

Thanks,
Kumar. 

On 3/2/18, 2:59 PM, "Kumar Subramanian" <kumarsubrama@vmware.com> wrote:

    Ok, I will try to build the controller image and see. Will keep you posted.
    
    On 3/2/18, 2:39 PM, "Tyson Norris" <tnorris@adobe.com.INVALID> wrote:
    
        Thanks Carlos - I think you’re right. 
        
        
        
        Kumar you can either build the controller image with that PR, or else you should be
able to manually set the docker cmd, e.g. /bin/sh -c \"exec /init.sh 0 >> /dev/stdout\”
on the dcos service for controller; 
        
        
        
        I think you will have similar issue with invoker, mostly because this universe is
far out of date from current openwhisk images. 
        
        
        
        For invoker can you use the docker cmd as /bin/sh -c \"exec /init.sh --name $LIBPROCESS_IP
>> /dev/stdout\”
        
        
        
        Additionally, the env vars (both invoker and controller) have changed substantially,
so I would expect a few hiccups there as well. 
        
        
        
        We are working on getting updates to the universe so that our internal deployment
details are not included, and it will actually work with recent openwhisk images (and stay
working) but haven’t gotten everything set just yet. 
        
        
        
        Hope that helps
        
        Tyson
        
        
        
        > On Mar 2, 2018, at 2:21 PM, Carlos Santana <csantana23@gmail.com> wrote:
        
        > 
        
        > Maybe for the init.sh this PR is related
        
        > https://urldefense.proofpoint.com/v2/url?u=https-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Fgithub.com-252Fapache-252Fincubator-2Dopenwhisk-252Fpull-252F3374-252Ffiles-2523diff-2D8f445fbdf6253dd176975ff6c629def4R18-26data-3D02-257C01-257Ctnorris-2540adobe.com-257C605cc50c7a484ccb833708d5808bfe64-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636556261107863657-26sdata-3Dtk8Des10hubLs7FNSgzDlsk1ibxDTIqSlXti-252FcAUyz0-253D-26reserved-3D0&d=DwIGaQ&c=uilaK90D4TOVoH58JNXRgQ&r=F5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo&m=LUthdew4Dt10vSAZSYRBbREqgwWk2PUWc4KDBJtt0uU&s=3UqWljTQjItMnzWhPrsfD1AF2IX6abtc9dYRfrxb2_M&e=
        
        > 
        
        > 
        
        > On Fri, Mar 2, 2018 at 5:09 PM Tyson Norris <tnorris@adobe.com.invalid>
        
        > wrote:
        
        > 
        
        >> Check your marathon/dcos service config to verify what image is used, and
        
        >> that you have the latest image pulled?
        
        >> 
        
        >> The default should be openwhisk/controller - but I see that universe
        
        >> package marathon config is not set to force pull, so if you are using that
        
        >> image, make sure you have pulled the latest manually (or change the config
        
        >> to force pull in dcos/marathon ui).
        
        >> 
        
        >> Tyson
        
        >> 
        
        >>> On Mar 2, 2018, at 12:45 PM, Kumar Subramanian <kumarsubrama@vmware.com>
        
        >> wrote:
        
        >>> 
        
        >>> Hi,
        
        >>> I have installed the following in DCOS successfully:
        
        >>> 1. Apigateway
        
        >>> 2. Exhibitor-dcos
        
        >>> 3. Kafka (name given is mykafka at the time of installation)
        
        >>> 4. Whisk-couchdb
        
        >>> 5. Consul
        
        >>> 6. Registrator
        
        >>> 
        
        >>> Eror when deploying Whisk-Controller in DCOS:
        
        >>> When I tried to deploy whisk-controller with default settings, then the
        
        >> service fails to deploy (it just kills and redploys the service
        
        >> continuously on its own when deploying)
        
        >>> 
        
        >>> Here is the content in the Error and Output
        
        >>> 
        
        >>> STDERR:
        
        >>> (AT BEGINNING OF FILE)
        
        >>> I0302 20:38:35.176177 19822 exec.cpp:162] Version: 1.2.3
        
        >>> I0302 20:38:35.180703 19824 exec.cpp:237] Executor registered on agent
        
        >> 995020e0-5129-44a3-8cf4-65900838b3af-S6
        
        >>> docker: Error response from daemon: Container command 'init.sh' not
        
        >> found or does not exist..
        
        >>> 
        
        >>> OUTPUT:
        
        >>> (AT BEGINNING OF FILE)
        
        >>> Registered docker executor on 10.0.6.55
        
        >>> Starting task whisk-controller.adb62c44-1e59-11e8-8754-3afdc003616b
        
        >>> 
        
        >>> Can you please provide your valuable inputs on how to get
        
        >> whisk-controller deployed in dcos?
        
        >>> 
        
        >>> Thanks,
        
        >>> Kumar.
        
        >>> 
        
        >> 
        
        >> 
        
        
        
        
    
    

Mime
View raw message