openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tyson Norris <tnor...@adobe.com.INVALID>
Subject Re: Install Api Gateway in dcos
Date Thu, 01 Mar 2018 20:43:41 GMT

On Mar 1, 2018, at 12:30 PM, Kumar Subramanian <kumarsubrama@vmware.com<mailto:kumarsubrama@vmware.com>>
wrote:

Hi Tyson/Dragos,
I was able to progress and install apiGateway. The change I made was to the config; specifically
the “acceptedResourceRoles”: [“slave_public”]; I set this to null and I was able to
deploy the apiGateway Successfully.

Question: Is it necessary to set the value to “slave_public” ?

This depends on your cluster config and how you want to expose the apigateway to public users
that should not have other access to your cluster.

See https://docs.mesosphere.com/1.9/deploying-services/expose-service/

Tyson

Thanks,
Kumar.

On 3/1/18, 12:18 PM, "Tyson Norris" <tnorris@adobe.com.INVALID<mailto:tnorris@adobe.com.INVALID>>
wrote:

   Ok, you might want to verify your agents are running properly, with the resource attributes
that you expect.

   On the mesos ui, click the “Agents” nav at the top, and verify the apigateway resource
requirements can be satisfied (default is 0.5 cpu, 256MB memory, and constraint for unique
hostname)



On Mar 1, 2018, at 11:09 AM, Kumar Subramanian <kumarsubrama@vmware.com<mailto:kumarsubrama@vmware.com>>
wrote:



Hi Tyson,

Under Debug>>Recent Resource Offers, I only see “Rejected offer analysis is not currently
supported.” Also on the /mesos pages >> Offers (tab), the table contents is empty.



Thanks,

Kumar.



On 3/1/18, 10:29 AM, "Tyson Norris" <tnorris@adobe.com.INVALID<mailto:tnorris@adobe.com.INVALID>>
wrote:



  Hi Kumar -



  If it is stuck in “waiting” status check the debug page for that service in DCOS gui
(https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttps-2D3A-5F-5Fdocs.mesosphere.com-5F1.10-5Fmonitoring-5Fdebugging-5Fgui-2D2Ddebugging-5F-2526d-253DDwIGaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DPMpLWk-2DomxV9OEMjTizFWDKWJNG85Nf-2DIsvoagjL6X4-2526s-253DTOHffBumq67TyI2YR7oFirrjGztyjBTa1J6kJinwv6I-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com-257Cb9a19b0d304c4775a32808d57fa7fc19-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636555281818017113-26sdata-3D1RzoZScZnamq-252FZWEImlDNYqAfloLWjcjNCv7vG2hu0Y-253D-26reserved-3D0-3D%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3D5Fs4kuHy5ihfjroTdU5Q1qPItydbH9BE5-9DnJmknUU%26s%3D585OO58K8U6ikUcmpojqPLXUwLI-0Ukoft-Cs6KuOfE%26e&data=02%7C01%7Ctnorris%40adobe.com%7Ca5af1f458b8845a506f808d57fb351ec%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555330503435891&sdata=AVvEzBIYC0ar%2BEl3oKD5wW2wLB2wG9lFC8J09YTy1So%3D&reserved=0=)
to see why offers are not matching.







  Tyson







  On Mar 1, 2018, at 10:05 AM, Kumar Subramanian <kumarsubrama@vmware.com<mailto:kumarsubrama@vmware.com><mailto:kumarsubrama@vmware.com>>
wrote:







  Hi Dragos,



  One more information I noticed is that; as the apigateway status is in “waiting” status,
the Error icon right next to it states “DC/OS has been waiting for resources and is unable
to complete this deployment for XX minutes.







  Thanks,



  Kumar.







  On 3/1/18, 9:28 AM, "Kumar Subramanian" <kumarsubrama@vmware.com<mailto:kumarsubrama@vmware.com><mailto:kumarsubrama@vmware.com>>
wrote:







     Hi Dragos,







     I am not sure I understood your point about “        Note that by default the Gateway
listens on this domain defined in config







             at [2] ( <marathon-app-name>.gw.<your-domain-name>). Once the controller
is







             installed in the cluster, it's accessible on controller.gw.<your-domain-name>,







             assuming the Marathon app name for the OpenWhisk Controller is called







             "controller" “















     apigateway is the first app that I tried to install on DCOS. Is there any place I have
to define the url? (( <marathon-app-name>.gw.<your-domain-name>) and may be I
am missing that? The only Url I mentioned is the default one in the Environment settings of
apigateway package (during installation). The default value was "default":https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttp-2D3A-5F-5Fmarathon.mesos-2D3A8080-2526d-253DDwIGaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DSnzzg-2DsR6t5CY7El-5F-2DGNWwuD-5FWMAn1nbqP6taqWUSXo-2526s-253DztUsE0shjeKqrwdPc2TAGnBPCWlRPjo-5FHE9TL74FUcU-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com<http://2526m-253DSnzzg-2DsR6t5CY7El-5F-2DGNWwuD-5FWMAn1nbqP6taqWUSXo-2526s-253DztUsE0shjeKqrwdPc2TAGnBPCWlRPjo-5FHE9TL74FUcU-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com>%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3DPMpLWk-omxV9OEMjTizFWDKWJNG85Nf-IsvoagjL6X4%26s%3DtzvuX_C6QuK3rjJu7OFDRiN7_cfu4lSdlNGYNlLwahg%26e&data=02%7C01%7Ctnorris%40adobe.com<http://40adobe.com>%7Cb9a19b0d304c4775a32808d57fa7fc19%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555281818017113&sdata=o6y0ObDTz7VJvoFLYZvH8LYvosiUJuTkOsnCbngrs5o%3D&reserved=0=<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttp-2D3A-5F-5F40adobe.com-2526d-253DDwIGaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DPMpLWk-2DomxV9OEMjTizFWDKWJNG85Nf-2DIsvoagjL6X4-2526s-253Dg6fXy7PHB1uI99PICsXuX5KF9n7OGW60qTMuc5jw1Hw-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com-257Cb9a19b0d304c4775a32808d57fa7fc19-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636555281818017113-26sdata-3DJ6lvKvCFcun4Y-252BFfdN-252B5Wrk4bArSYohNJsGDq7DNK6k-253D-26reserved-3D0-3D%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3D5Fs4kuHy5ihfjroTdU5Q1qPItydbH9BE5-9DnJmknUU%26s%3D-zIuIA6ofqCeJxgQk-85wan4ipT9SjQTV5Jm90hw-F8%26e&data=02%7C01%7Ctnorris%40adobe.com%7Ca5af1f458b8845a506f808d57fb351ec%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555330503435891&sdata=hqKDsMrKfyTEqSp7gwNO9l7te1dd4xOhXReEU0jQbxo%3D&reserved=0=>%7C4c8760a6baa149a4998608d57f9f015b%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555243255443290&sdata=g6fpgmaBZSJyuCkfuYx2fq%2FlUn%2BOTlu%2BfzI6XtuFt5Y%3D&reserved=0=;
and I kept it as is when installing.















     Thanks,







     Kumar.















     On 3/1/18, 9:18 AM, "Kumar Subramanian" <kumarsubrama@vmware.com<mailto:kumarsubrama@vmware.com><mailto:kumarsubrama@vmware.com>>
wrote:















         Hi Dragos,







         Here is the DCOS Version







         DC/OS VERSION: 1.9.4















         Marathon Version: 1.4.7















         Thanks,







         Kumar.















         On 2/28/18, 11:10 PM, "Dascalita Dragos" <ddragosd@gmail.com<mailto:ddragosd@gmail.com><mailto:ddragosd@gmail.com>>
wrote:















             Hi Kumar,







             Can you provide details on the DCOS version as well ?















             *"...The (api gateway) service status shows waiting and there are no logs;







             nothing getting deployed also...."*







             Depending on the DCOS version, you may find in the DCOS UI debug







             information in regards to the resource offered by Mesos and what's missing.







             [1] It's possible that some constraints are not matched, and Marathon is







             still waiting to get offers, which would explain this effect you're seeing.







             Note that by default the Gateway listens on this domain defined in config







             at [2] ( <marathon-app-name>.gw.<your-domain-name>). Once the controller
is







             installed in the cluster, it's accessible on controller.gw.<your-domain-name>,







             assuming the Marathon app name for the OpenWhisk Controller is called







             "controller". Same goes for the "invoker": invoker.gw.<your-domain-name>.







             Same for Exhibitor, CouchDB etc, any other app installed in the cluster is







             exposed in this way. Of course, these domain names can be easily configured







             differently in NGINX, I'm just explaining the default rules.















             We might have to provide a DCOS universe for 1.9 or 1.10 as well. We've







             tested with both versions successfully; we need to strip customizations







             particular to our deployment, prior to sharing the updated universe.















             HTH,







             Dragos















             [1] - https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttps-2D3A-5F-5Fdocs.mesosphere.com-5F1.10-5Fmonitoring-5Fdebugging-5Fgui-2D2Ddebugging-5F-2526d-253DDwIFaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DPq6qbuCjIV0NgXrQUGgzHlpwkfQ1iR-2DhlycfGmbR5-5F4-2526s-253D67DJMsbbLqbhR82ScYfqZ6g-2DhvjuOMnMeGOq-2DM6zmFQ-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com-257C4c8760a6baa149a4998608d57f9f015b-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636555243255443290-26sdata-3DjuKGgSDAFtt0ci1tG-252BqQVJ9FP1c-252FFgRjSAb1i2H-252B4yk-253D-26reserved-3D0-3D%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3DPMpLWk-omxV9OEMjTizFWDKWJNG85Nf-IsvoagjL6X4%26s%3D_IDq-W-Z6d88UJDT16fBwKY0toA3w2mmqCFoYpjT2BU%26e&data=02%7C01%7Ctnorris%40adobe.com%7Cb9a19b0d304c4775a32808d57fa7fc19%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555281818017113&sdata=IEzsd3EXx2IRqjZ%2FfgcOxKnwKfmnGgvpaSHeVfL%2FaMU%3D&reserved=0=







             [2] -







             https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttps-2D3A-5F-5Fgithub.com-5Fadobe-2D2Dapiplatform-5Fapigateway-5Fblob-5Fmaster-5Fapi-2D2Dgateway-2D2Dconfig-5Fconf.d-5Fmarathon-2D5Fapis.conf-2D23L35-2526d-253DDwIFaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DPq6qbuCjIV0NgXrQUGgzHlpwkfQ1iR-2DhlycfGmbR5-5F4-2526s-253D6BVUN80-2DtqxdqO0yYyI2IuXRoe5XKGEUUwhJhjD8J-2Do-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com-257C4c8760a6baa149a4998608d57f9f015b-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636555243255443290-26sdata-3DhebZSZOdo2KqMRQpZ4LXN-252FrT8VUX39cbedV1sVtQHKw-253D-26reserved-3D0-3D%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3DPMpLWk-omxV9OEMjTizFWDKWJNG85Nf-IsvoagjL6X4%26s%3DE0wZQfDnRsmU1IHqg6a8oxawvQdX-ETu_a-qdjTg_2Q%26e&data=02%7C01%7Ctnorris%40adobe.com%7Cb9a19b0d304c4775a32808d57fa7fc19%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555281818017113&sdata=xaJywPXa3h5TveaA84b2ATW6D%2FjNOdPPr5nSArKM5%2BI%3D&reserved=0=































             On Wed, Feb 28, 2018 at 6:08 PM Carlos Santana <csantana23@gmail.com<mailto:csantana23@gmail.com><mailto:csantana23@gmail.com>>
wrote:















  Hi Kumar welcome to list















   Adobe team is currently deploying OpenWhisk on DCOS/Mesos I bet one of







  them will be able to assist you on this task and point you int he right







  direction















  The file you point is no longer on the repo, Maybe  Dragos or Tyson could







  also clarify that and the apigateway issues.















  -- Carlos















  On Wed, Feb 28, 2018 at 8:27 PM Kumar Subramanian <kumarsubrama@vmware.com<mailto:kumarsubrama@vmware.com><mailto:kumarsubrama@vmware.com>















  wrote:















  Hi,















  I am trying to install OpenWhisk on Mesos Cluster.































  I followed the steps described at















  https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttps-2D3A-5F-5Fgithub.com-5Fapache-5Fincubator-2D2Dopenwhisk-2D2Ddevtools-5Ftree-5F1f42e6057de42babc2bf88870fabb61d172d728d-5Fdcos-2D2Duniverse-2526d-253DDwIFaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DPq6qbuCjIV0NgXrQUGgzHlpwkfQ1iR-2DhlycfGmbR5-5F4-2526s-253DQTfB2-2DjYGp7UtoXJxEX8WZuWVF8NfYEZiu3nZ9GCJ3g-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com-257C4c8760a6baa149a4998608d57f9f015b-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636555243255443290-26sdata-3DKhtAoHB3bWetSpSfL77pvKUYq88W4eSoaMd-252Bh2hfQfw-253D-26reserved-3D0-3D%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3DPMpLWk-omxV9OEMjTizFWDKWJNG85Nf-IsvoagjL6X4%26s%3DXmc9lRlDNoCTgAPGfnf8qcUew5ZZBrLMzRw0Bcup64k%26e&data=02%7C01%7Ctnorris%40adobe.com%7Cb9a19b0d304c4775a32808d57fa7fc19%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555281818017113&sdata=4CB%2FG0Lo3kip3Ya6rouLa0sY%2Bg33tYAg8D2pACsj%2FPY%3D&reserved=0=































  *Steps Completed:*















    1. In the universe home directory, run command ./scripts/build.sh.







    2. Upload /target/repo-up-to-1.8.json to a host service (e.g. AWS S3)







       - Make sure Content-Type =







       application/vnd.dcos.universe.repo+json in the file's headers.







    3. In DC/OS admin console, under System > Overview > Repositories, add







    the link to the new repository.































  Note: I’ve attached the repository file repo-uo-to-1.8.json.































  *Next:*















    1. I added the repository to dcos







    2. Installed redis successfully.







       1. Container port : 6379







       2. Host: <host_ip>







       3. Ports: 3774







    3. Then I tried to install api gateway package (default settings –







    mentioned below)































  *Stage I am stuck at:*































    1. Api Gateway Installation







       1. Environment: MarathonHost: https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Furldefense.proofpoint.com%2Fv2%2Furl%3Fu%3Dhttps-3A__na01.safelinks.protection.outlook.com_-3Furl-3Dhttps-253A-252F-252Furldefense.proofpoint.com-252Fv2-252Furl-253Fu-253Dhttp-2D3A-5F-5Fmarathon.mesos-2D3A8080-2526d-253DDwIFaQ-2526c-253DuilaK90D4TOVoH58JNXRgQ-2526r-253DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo-2526m-253DPq6qbuCjIV0NgXrQUGgzHlpwkfQ1iR-2DhlycfGmbR5-5F4-2526s-253DiJzQ1LOzvwJ64ic-5FjZqFpVNTGMNzMROVn2tOwIqoiOE-2526e-26data-3D02-257C01-257Ctnorris-2540adobe.com-257C4c8760a6baa149a4998608d57f9f015b-257Cfa7b1b5a7b34438794aed2c178decee1-257C0-257C0-257C636555243255443290-26sdata-3DFhD86SS-252Fq3THkHDtJHWLhy6cGhUHQR3nHdOXi9mbdpQ-253D-26reserved-3D0-3D%26d%3DDwIGaQ%26c%3DuilaK90D4TOVoH58JNXRgQ%26r%3DF5C8fYlpBJ270qrdwLq2iRQrPd1CLap8zItxk8laWpo%26m%3DPMpLWk-omxV9OEMjTizFWDKWJNG85Nf-IsvoagjL6X4%26s%3DHOupLGFXhlE2lI_SdK5Wwixwbe92bkD1DwHtUotAxeo%26e&data=02%7C01%7Ctnorris%40adobe.com%7Cb9a19b0d304c4775a32808d57fa7fc19%7Cfa7b1b5a7b34438794aed2c178decee1%7C0%7C0%7C636555281818017113&sdata=W6mnCBb19bA525HGjN3ZKZzycPtTLG%2F2OuIqI5V4dLY%3D&reserved=0=































  *What’s happening?* The (api gateway) service status shows waiting and







  there are no logs; nothing getting deployed also.































  *Questions:*















    1. Why is it stuck and not even getting deployed?







    2. How can I debug







    3. Where can I look for logs







    4. Is there anything wrong with my settings for api-gateway(from json







    file attached)?







    5. Is there anything else that needs to be installed?































  Thanks,















  Kumar.












































































Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message