openwhisk-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 张海勇 <zhy...@mail.ustc.edu.cn>
Subject issue about mountPath
Date Wed, 05 Jul 2017 07:04:19 GMT

Hi Daniel Lavine,


When I deploy components such as consul nginx by CLI "ansible-playbook -i environments/kube
openwhisk.yml", 
there are some mountPath in the yml config file , where can I get these files ?




for example: nginx






best regards,
Zhang Haiyong
-----原始邮件-----
发件人:"Daniel Lavine" <dlavine@us.ibm.com>
发送时间:2017-06-23 00:12:21 (星期五)
收件人: "张海勇" <zhy989@mail.ustc.edu.cn>
抄送: dev@openwhisk.incubator.apache.org
主题: Re: issue about Image danlavine/whisk_config:v1.5.6



Hey Zhanghaiyong,

For theses types of issues, I would open up an issue against the github repo directly so that
it can be better addressed by the people who know most about that code base. Also, we would
be able to integrate any code changes that might need to happen. That being said, I would
take a look at these instructions https://github.com/apache/incubator-openwhisk-deploy-kube#configure-openwhisk.
Whenever deploying Docker images --> Kubernetes Pods you should always be using the Kubernetes
cli "kubectl", not Docker commands directly.

git repo: https://github.com/apache/incubator-openwhisk-deploy-kube/issues

Thanks,

Dan Lavine

张海勇 ---06/22/2017 07:36:07 AM---Hi Daniel Lavine, I am a learner about deploying openwhisk
on kubernetes, when I run the script

From: 张海勇 <zhy989@mail.ustc.edu.cn>
To: dlavine@us.ibm.com
Cc: dev@openwhisk.incubator.apache.org
Date: 06/22/2017 07:36 AM
Subject: issue about Image danlavine/whisk_config:v1.5.6





Hi Daniel Lavine,

I am a learner about deploying openwhisk on kubernetes, when I run the script

$TRAVIS_KUBE_VERSION=v1.5.6 TRAVIS_ETCD_VERSION=v3.0.14 ./setup.sh
$TRAVIS_KUBE_VERSION=v1.5.6 ./build.sh
$kubectl -n openwhisk logs configure-openwhisk-xxxxx

there is no log , then I download the image whisk_config:v1.5.6, and run

$docker run danlavine/whisk_config:v1.5.6 /incubator-openwhisk-deploy-kube/configure/configure.sh

and noted that the command kubectl did not run successfully, the log is as below:

The connection to the server localhost:8080 was refused - did you specify the right host or
port?

so I think the kubernetes environments in the image (danlavine/whisk_config:v1.5.6) is not
complete.

need you to confirm , thanks !


Best regards,
zhanghaiyong



Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message