openwebbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerhard Petracek <gerhard.petra...@gmail.com>
Subject Re: Yan: Yan: Help! OWB on JBoss 5.x not running
Date Wed, 18 Jan 2012 20:51:19 GMT
hi,

maybe this case, but not all cases. esp. not with our current approach
which just tries to fix the new urls if they wouldn't work.
(we discussed it already...)

regards,
gerhard



2012/1/18 Mark Struberg <struberg@yahoo.de>

> Hi!
>
> Nope, should be possible without.
>
> We also came across a few issues within the AnnotatedType in the CDI spec.
> The effect is that we cannot completely replica our internal bean
> definition with the THIRDPARTY ones (which use the AnnotatedType), because
> the AnnotatedType e.g. doesn't know anything about it's supertypes, etc.
> This at least destroys our original plan to move our functionality
> completely over to AnnotatedType creation and modification.
>
> The AnnotationDB itself is already forked, bug fixed and now a part of OWB
> itself. Thus we should also be able to add the VFS stuff.
>
> LieGrue,
> strub
>
>
>
>
> >________________________________
> > From: Gerhard Petracek <gerhard.petracek@gmail.com>
> >To: user@openwebbeans.apache.org
> >Sent: Tuesday, January 17, 2012 10:15 AM
> >Subject: Re: Yan: Yan: Help! OWB on JBoss 5.x not running
> >
> >
> >@mark:
> >we should really think about finishing the new classpath scanner.
> >(we can't fix all constellations without it.)
> >
> >
> >regards,
> >gerhard
> >
> >
>

Mime
View raw message