openwebbeans-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafael Pestano <rmpest...@yahoo.com.br>
Subject Re: Yan: Yan: Help! OWB on JBoss 5.x not running
Date Thu, 12 Jan 2012 17:53:48 GMT
more info here: https://issues.jboss.org/browse/JBVFS-147

maybe it helps.

-- 
Att, 

Rafael M. Pestano

Desenvolvedor Java Cia. de Processamento de Dados do Rio Grande do Sul
Graduando em Ciência da Computação UFRGS

@realpestano
http://code.google.com/p/jsf-conventions-framework/



________________________________
De: Gurkan Erdogdu <gurkanerdogdu@yahoo.com>
Para: "user@openwebbeans.apache.org" <user@openwebbeans.apache.org> 
Enviadas: Quinta-feira, 12 de Janeiro de 2012 14:50
Assunto: Yan: Yan: Help! OWB on JBoss 5.x not running


Problem is that scannotation has problems with JBoss 5 VFS. IMO, you have to get scannotation
source and update it to work with vfs:// protocol.

Gurkan



________________________________
Kimden: Oleg Varaksin <ovaraksin@googlemail.com>
Kime: user@openwebbeans.apache.org 
Gönderildiği Tarih: 12 Ocak 2012 18:38 Perşembe
Konu: Re: Yan: Help! OWB on JBoss 5.x not running

Hi Gurkan,

I have scannotation-1.0.2.jar below WEB-INF/lib. This is already the
last version. Do you think, I should place it into JBoss lib folder by
reason of JBoss classloader?

Thanks. Oleg.

2012/1/12 Gurkan Erdogdu <gurkanerdogdu@yahoo.com>:
> Hi Oleg,
>
> Problem is that OWB Scannotation uses file related logic to resolve metadata
> etc. Probably current scanner implementation (using scannotation) must be
> updated for JBoss. In JBoss there is a vfs:// related URLs that may not work
> with current scanner.
>
> Regards;
>
> Gurkan Erdogdu
> CTO, http://software.mechsoft.com.tr
>
> ________________________________
> Kimden: Oleg Varaksin <ovaraksin@googlemail.com>
> Kime: user@openwebbeans.apache.org
> Gönderildiği Tarih: 12 Ocak 2012 16:02 Perşembe
> Konu: Re: Help! OWB on JBoss 5.x not running
>
> Hi Rudi,
>
> Thanks for your reply! Yes, I have an empty beans.xml
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://java.sun.com/xml/ns/javaee";
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
>     xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
> http://java.sun.com/xml/ns/javaee/beans_1_0.xsd";>
>
> </beans>
>
> I don't use geronimo-interceptor because javax.enterprise.cdi-api
> already includes jboss-interceptor. But I will try it.
>
> Thanks. Oleg.
>
> 2012/1/12 Rudy De Busscher <rdebusscher@gmail.com>:
>> Hello Oleg,
>>
>> Did you define a (empty) beans.xml file under web-inf directory ?
>>
>> When I useOWB in Tomcat (different thing but for OWB comparable to a J2EE
>> 5
>> server like Jboss 5) I have these dependencies (some of them, you don't
>> have
>> at this moment)
>>
>>         <!-- JSR-299 Impl -->
>>
        <dependency>
>>             <groupId>org.apache.openwebbeans</groupId>
>>             <artifactId>openwebbeans-impl</artifactId>
>>             <version>${owb.version}</version>
>>             <scope>runtime</scope>
>>         </dependency>
>>
>>         <dependency>
>>             <groupId>org.apache.openwebbeans</groupId>
>>            
<artifactId>openwebbeans-resource</artifactId>
>>             <version>${owb.version}</version>
>>         </dependency>
>>
>>         <!-- Interceptor API -->
>>         <dependency>
>>             <groupId>org.apache.geronimo.specs</groupId>
>>             <artifactId>geronimo-interceptor_1.1_spec</artifactId>
>>             <version>${geronimo_interceptor.version}</version>
>>         </dependency>
>>
>>
        <!-- JSF Plugin -->
>>         <dependency>
>>             <groupId>org.apache.openwebbeans</groupId>
>>             <artifactId>openwebbeans-jsf</artifactId>
>>             <version>${owb.version}</version>
>>         </dependency>
>>
>>         <!-- Web Plugin -->
>>         <dependency>
>>             <groupId>org.apache.openwebbeans</groupId>
>>
            <artifactId>openwebbeans-web</artifactId>
>>             <version>${owb.version}</version>
>>         </dependency>
>>
>>         <!-- JSR 299 API -->
>>         <dependency>
>>             <groupId>org.apache.geronimo.specs</groupId>
>>             <artifactId>geronimo-jcdi_1.0_spec</artifactId>
>>             <version>${geronimo_cdi.version}</version>
>>        
</dependency>
>>
>>         <!-- JSR 330 API -->
>>         <dependency>
>>             <groupId>org.apache.geronimo.specs</groupId>
>>             <artifactId>geronimo-atinject_1.0_spec</artifactId>
>>             <version>${geronimo_atinject.version}</version>
>>         </dependency>
>>
>>         <!-- SPI API -->
>>         <dependency>
>>            
<groupId>org.apache.openwebbeans</groupId>
>>             <artifactId>openwebbeans-spi</artifactId>
>>             <version>${owb.version}</version>
>>         </dependency>
>>
>>     <properties>
>>         <owb.version>1.1.2</owb.version>
>>         <geronimo_interceptor.version>1.0</geronimo_interceptor.version>
>>         <geronimo_cdi.version>1.0</geronimo_cdi.version>
>>         <geronimo_atinject.version>1.0</geronimo_atinject.version>
>>
>>    
</properties>
>>
>>
>> Regards
>> Rudy
>>
>>
>> --
>> Rudy De Busscher
>> http://www.c4j.be
>>
>>
>> On 12 January 2012 14:05, Oleg Varaksin <ovaraksin@googlemail.com> wrote:
>>>
>>> Hello,
>>>
>>> I'm new in this mailing list and I'm trying to use OpenWebBeans along
>>> with JSF 2. Our app server is JBoss 5.0.1.GA. There is already a post
>>> from Thomas and answer from Mark about the OWB and JBoss 5.x.
>>> Unfortunately, but I can not get deployed a simple demo web app in
>>> JBoss 5.0.1. I would be very thankful if somebody could help me. I
>>> show my confguration at
first.
>>>
>>> My pom.xml with dependencies: http://paste.kde.org/185492/
>>>
>>> My JSF beans are simple. They use @Named, @ViewScoped and
>>> @SessionScoped annotations. @SessionScoped is defined as
>>> javax.enterprise.context.SessionScoped and @ViewScoped as an extension
>>> ViewScopedExtension.java placed under
>>> src/main/java/org/apache/webbeans/jsf/scopes. Here is it:
>>> http://paste.kde.org/185504/
>>>
>>> I have an empty beans.xml below resources/META-INF and a text file
>>> javax.enterprise.inject.spi.Extension below
>>> resources/META-INF/services. The content of this text file is only one
>>> line:
org.apache.webbeans.jsf.scopes.ViewScopedExtension
>>>
>>> My web.xml has a listener
>>> org.apache.webbeans.servlet.WebBeansConfigurationListener. Here is
>>> this configuration: http://paste.kde.org/185510/
>>>
>>> Now, if I try to deploy this small web app, I get an exception that
>>> "Initialization of the WebBeans container has failed". Here is the
>>> entire log-file: http://paste.kde.org/185522/
>>>
>>> Do you have an idea what is wrong here? Missing dependencies or wrong
>>> OWB config.? It works fine without OWB.
>>>
>>> Thanks a lot in advance for your replies!
>>>
>>> Oleg Varaksin
>>>
>>> Blog: http://ovaraksin.blogspot.com/
>>
>>
>>
>>
>>
>
> 

Mime
View raw message