openwebbeans-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gurkan Erdogdu <gurkanerdo...@yahoo.com>
Subject Re: [VOTE] Release OpenWebBeans 1.0.0-incubating-M2
Date Sat, 23 May 2009 05:17:04 GMT

Hi James;

Yes, I did it. I removed old tag and artifacts and I generated a new release candidate and
tag.

Please have a look at it

Thanks;

--Gurkan




________________________________
From: James Carman <jcarman@carmanconsulting.com>
To: openwebbeans-dev@incubator.apache.org
Sent: Saturday, May 23, 2009 1:05:14 AM
Subject: Re: [VOTE] Release OpenWebBeans 1.0.0-incubating-M2

IMHO, you should really generate a new release candidate (along with
tags).  That's the way we do it in Commons.

On Fri, May 22, 2009 at 1:43 PM, Gurkan Erdogdu <gurkanerdogdu@yahoo.com> wrote:
> Ok, I have re-uploaded the artifacts and svn tag. Locations are the same. New svn tag
is 777602.
>
> Thanks;
>
> -- Gurkan
>
>
>
>
> ________________________________
> From: Gurkan Erdogdu <gurkanerdogdu@yahoo.com>
> To: openwebbeans-dev@incubator.apache.org
> Sent: Friday, May 22, 2009 12:48:39 PM
> Subject: Re: [VOTE] Release OpenWebBeans 1.0.0-incubating-M2
>
>>>>Embedded error: Prohibited package name: java.lang
>
>>>>If anyone knows how to avoid this problem, let me know...
> Sorry, I am not a maven expert. Maybe Mark can answer this question.
>
>
>>>>Running RAT on the source reveals the following files missing
> apache src license headers. These must be fixed. You should be running
> RAT as part of a >>>build or as part of the release process...
>
> Is it required to retag into svn? Or is it enough to checkout the tagged version and
applying changes and then commit?
>
> Thanks;
>
> --Gurkan
>
>
>
>
>
>
> ________________________________
> From: Kevan Miller <kevan.miller@gmail.com>
> To: openwebbeans-dev@incubator.apache.org
> Sent: Friday, May 22, 2009 6:10:55 AM
> Subject: Re: [VOTE] Release OpenWebBeans 1.0.0-incubating-M2
>
>
>
> Afraid that I'm currently unable to build. So, I can't fully review...
>
> My build issue seems to be a Mac OS / mvn issue. I'm failing with:
>
> [INFO] ------------------------------------------------------------------------
> [INFO] Building OpenWebBeans :: WebBeans-API
> [INFO]    task-segment: [clean, install]
> [INFO] ------------------------------------------------------------------------
> [INFO] [clean:clean]
> [INFO] Deleting directory /Users/kevan/tmp/owb/openwebbeans-1.0.0-incubating-M2/webbeans-api/target
> [INFO] [remote-resources:process {execution: default}]
> [INFO] inceptionYear not specified, defaulting to 2009
> [INFO] [resources:resources]
> [WARNING] Using platform encoding (MacRoman actually) to copy filtered resources, i.e.
build is platform dependent!
> [INFO] Copying 0 resource
> [INFO] Copying 4 resources
> [INFO] [compiler:compile]
> [INFO] Compiling 65 source files to /Users/kevan/tmp/owb/openwebbeans-1.0.0-incubating-M2/webbeans-api/target/classes
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Fatal error compiling
>
> Embedded error: Prohibited package name: java.lang
>
> If anyone knows how to avoid this problem, let me know...
>
> Running RAT on the source reveals the following files missing apache src license headers.
These must be fixed. You should be running RAT as part of a build or as part of the release
process...
>
>
> samples/reservation/src/main/webapp/main.css
> webbeans-geronimo/pom.xml
> webbeans-jpa/pom.xml
> webbeans-jsf/pom.xml
>
> --kevan
>
>
>



      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message