openwebbeans-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From build...@apache.org
Subject svn commit: r1015588 - /websites/staging/openwebbeans/trunk/content/
Date Mon, 17 Jul 2017 13:21:24 GMT
Author: buildbot
Date: Mon Jul 17 13:21:24 2017
New Revision: 1015588

Log:
Staging update by buildbot for openwebbeans

Modified:
    websites/staging/openwebbeans/trunk/content/   (props changed)
    websites/staging/openwebbeans/trunk/content/cdi_explained.html
    websites/staging/openwebbeans/trunk/content/documentation.html
    websites/staging/openwebbeans/trunk/content/download.html
    websites/staging/openwebbeans/trunk/content/faq.html
    websites/staging/openwebbeans/trunk/content/index.html
    websites/staging/openwebbeans/trunk/content/news.html
    websites/staging/openwebbeans/trunk/content/openwebbeans-impl.html
    websites/staging/openwebbeans/trunk/content/openwebbeans-tomcat.html
    websites/staging/openwebbeans/trunk/content/owb-eecontainers.html
    websites/staging/openwebbeans/trunk/content/owbsetup_ee.html
    websites/staging/openwebbeans/trunk/content/owbsetup_se.html

Propchange: websites/staging/openwebbeans/trunk/content/
------------------------------------------------------------------------------
--- cms:source-revision (original)
+++ cms:source-revision Mon Jul 17 13:21:24 2017
@@ -1 +1 @@
-1801814
+1802139

Modified: websites/staging/openwebbeans/trunk/content/cdi_explained.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/cdi_explained.html (original)
+++ websites/staging/openwebbeans/trunk/content/cdi_explained.html Mon Jul 17 13:21:24 2017
@@ -82,7 +82,7 @@ h2:hover > .headerlink, h3:hover > .head
 <h1 id="what-can-openwebbeans-as-cdi-container-do-for-you">What can OpenWebBeans as
CDI container do for you?<a class="headerlink" href="#what-can-openwebbeans-as-cdi-container-do-for-you"
title="Permanent link">&para;</a></h1>
 <h2 id="an-introduction-to-cdi">An introduction to CDI<a class="headerlink" href="#an-introduction-to-cdi"
title="Permanent link">&para;</a></h2>
 <p>Contexts and Dependency Injection for Java a.k.a. CDI is a JavaEE specification
with the number
-JSR-299 (CDI-1.0), JSR-346 (CDI-1.1/1.2) and JSR-365 (CDI-2.0 currently work in progress).
+JSR-299 (CDI-1.0), JSR-346 (CDI-1.1/1.2) and JSR-365 (CDI-2.0).
 Apache OpenWebBeans implements these standards. This page will give you an introduction to
features of
 CDI in general. We will add a special hint whenever a feature is ambiguous in the specification

 and OpenWebBeans implements it in a certain way which might be different on other CDI containers.</p>

Modified: websites/staging/openwebbeans/trunk/content/documentation.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/documentation.html (original)
+++ websites/staging/openwebbeans/trunk/content/documentation.html Mon Jul 17 13:21:24 2017
@@ -105,7 +105,7 @@ separate plugins.</p>
 <li><a href="openwebbeans-web.html">Web plugin</a></li>
 <li><a href="openwebbeans-el.html">EL plugins 1.0 &amp; 2.2</a></li>
 <li><a href="openwebbeans-jsf.html">JSF plugins 1.2 &amp; 2.x</a></li>
-<li><a href="openwebbeans-tomcat.html">Tomcat plugins 6 &amp; 7</a></li>
+<li><a href="openwebbeans-tomcat.html">Apache Tomcat plugins</a></li>
 </ul>
 <h3 id="technical-integration-plugins">Technical Integration Plugins<a class="headerlink"
href="#technical-integration-plugins" title="Permanent link">&para;</a></h3>
 <ul>

Modified: websites/staging/openwebbeans/trunk/content/download.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/download.html (original)
+++ websites/staging/openwebbeans/trunk/content/download.html Mon Jul 17 13:21:24 2017
@@ -86,10 +86,31 @@ h2:hover > .headerlink, h3:hover > .head
 <p>The GPG keys in the <a href="http://www.apache.org/dist/openwebbeans/KEYS">OpenWebBeans
KEYS file</a> to validate our releases.
 Read more about <a href="http://www.apache.org/info/verification.html">How we sign
Apache Releases</a></p>
 <hr />
+<h2 id="owb-20x">OWB-2.0.x<a class="headerlink" href="#owb-20x" title="Permanent
link">&para;</a></h2>
+<p>OWB-2.0.x implements the CDI-2.0 (JSR-365) specification.
+It uses a shaded version of ASM-5 for building our proxies and needs JavaSE 8 as minimum
version.</p>
+<h4 id="binaries">Binaries<a class="headerlink" href="#binaries" title="Permanent
link">&para;</a></h4>
+<p>The binary distribution contains all OpenWebBeans modules.</p>
+<ul>
+<li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/2.0.0/openwebbeans-distribution-2.0.0-binary.zip">openwebbeans-distribution-2.0.0-binary.zip</a></li>
+<li><a href="http://www.apache.org/dist/openwebbeans/2.0.0/openwebbeans-distribution-2.0.0-binary.zip.sha1">openwebbeans-distribution-2.0.0-binary.zip.sha1</a></li>
+<li><a href="http://www.apache.org/dist/openwebbeans/2.0.0/openwebbeans-distribution-2.0.0-binary.zip.asc">openwebbeans-distribution-2.0.0-binary.zip.asc</a></li>
+<li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/2.0.0/openwebbeans-distribution-2.0.0-binary.tar.gz">openwebbeans-distribution-2.0.0-binary.tar.gz</a></li>
+<li><a href="http://www.apache.org/dist/openwebbeans/2.0.0/openwebbeans-distribution-2.0.0-binary.tar.gz.sha1">openwebbeans-distribution-2.0.0-binary.tar.gz.sha1</a></li>
+<li><a href="http://www.apache.org/dist/openwebbeans/2.0.0/openwebbeans-distribution-2.0.0-binary.tar.gz.asc">openwebbeans-distribution-2.0.0-binary.tar.gz.asc</a></li>
+</ul>
+<h4 id="source">Source<a class="headerlink" href="#source" title="Permanent link">&para;</a></h4>
+<p>Should you want to build any of the above binaries, this source bundle is the right
one and covers them all.</p>
+<ul>
+<li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/2.0.0/openwebbeans-2.0.0-source-release.zip">openwebbeans-2.0.0-source-release.zip</a></li>
+<li><a href="http://www.apache.org/dist/openwebbeans/2.0.0/openwebbeans-2.0.0-source-release.zip.sha1">openwebbeans-2.0.0-source-release.zip.sha1</a></li>
+<li><a href="http://www.apache.org/dist/openwebbeans/2.0.0/openwebbeans-2.0.0-source-release.zip.asc">openwebbeans-2.0.0-source-release.zip.asc</a></li>
+</ul>
+<hr />
 <h2 id="owb-17x">OWB-1.7.x<a class="headerlink" href="#owb-17x" title="Permanent
link">&para;</a></h2>
 <p>OWB-1.7.x implements the full CDI-1.2 specification.
 It uses a shaded version of ASM-5 for building our proxies and needs JavaSE 7 as minimum
version.</p>
-<h4 id="binaries">Binaries<a class="headerlink" href="#binaries" title="Permanent
link">&para;</a></h4>
+<h4 id="binaries_1">Binaries<a class="headerlink" href="#binaries_1" title="Permanent
link">&para;</a></h4>
 <p>The binary distribution contains all OpenWebBeans modules.</p>
 <ul>
 <li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/1.7.4/openwebbeans-distribution-1.7.4-binary.zip">openwebbeans-distribution-1.7.4-binary.zip</a></li>
@@ -99,7 +120,7 @@ It uses a shaded version of ASM-5 for bu
 <li><a href="http://www.apache.org/dist/openwebbeans/1.7.4/openwebbeans-distribution-1.7.4-binary.tar.gz.sha1">openwebbeans-distribution-1.7.4-binary.tar.gz.sha1</a></li>
 <li><a href="http://www.apache.org/dist/openwebbeans/1.7.4/openwebbeans-distribution-1.7.4-binary.tar.gz.asc">openwebbeans-distribution-1.7.4-binary.tar.gz.asc</a></li>
 </ul>
-<h4 id="source">Source<a class="headerlink" href="#source" title="Permanent link">&para;</a></h4>
+<h4 id="source_1">Source<a class="headerlink" href="#source_1" title="Permanent
link">&para;</a></h4>
 <p>Should you want to build any of the above binaries, this source bundle is the right
one and covers them all.</p>
 <ul>
 <li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/1.7.4/openwebbeans-1.7.4-source-release.zip">openwebbeans-1.7.4-source-release.zip</a></li>
@@ -110,7 +131,7 @@ It uses a shaded version of ASM-5 for bu
 <h2 id="owb-12x">OWB-1.2.x<a class="headerlink" href="#owb-12x" title="Permanent
link">&para;</a></h2>
 <p>OWB-1.2.x implements the CDI-1.0 specification and internally already CDI-1.1.
 It uses a shaded version of ASM-5 for building our proxies and needs JavaSE 5 as minimum
version.</p>
-<h4 id="binaries_1">Binaries<a class="headerlink" href="#binaries_1" title="Permanent
link">&para;</a></h4>
+<h4 id="binaries_2">Binaries<a class="headerlink" href="#binaries_2" title="Permanent
link">&para;</a></h4>
 <p>The binary distribution contains all OpenWebBeans modules.</p>
 <ul>
 <li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/1.2.8/openwebbeans-distribution-1.2.8-binary.zip">openwebbeans-distribution-1.2.8-binary.zip</a></li>
@@ -124,7 +145,7 @@ It uses a shaded version of ASM-5 for bu
 The jars you need depends on what modules you include.
 They are all contained in the binary distribution.
 We will try to add complete lists of this in the future, meanwhile please ask on the list
or maybe look at the pom.xml for the modules you want to use.</p>
-<h4 id="source_1">Source<a class="headerlink" href="#source_1" title="Permanent
link">&para;</a></h4>
+<h4 id="source_2">Source<a class="headerlink" href="#source_2" title="Permanent
link">&para;</a></h4>
 <p>Should you want to build any of the above binaries, this source bundle is the right
one covers them all.</p>
 <ul>
 <li><a href="http://www.apache.org/dyn/closer.lua/openwebbeans/1.2.8/openwebbeans-1.2.8-source-release.zip">openwebbeans-1.2.8-source-release.zip</a></li>
@@ -136,7 +157,35 @@ We will try to add complete lists of thi
 <p>Older versions of Apache OpenWebBeans can be found in our <a href="http://archive.apache.org/dist/openwebbeans/">archives</a></p>
 <hr />
 <h3 id="maven-dep">Maven Dependencies<a class="headerlink" href="#maven-dep" title="Permanent
link">&para;</a></h3>
-<h4 id="apis-version">API:s<a class="headerlink" href="#apis-version" title="Permanent
link">&para;</a></h4>
+<h4 id="apis-version">APIs for OWB-2.0.x<a class="headerlink" href="#apis-version"
title="Permanent link">&para;</a></h4>
+<div class="codehilite"><pre><span class="nt">&lt;dependency&gt;</span>
+    <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
+    <span class="nt">&lt;artifactId&gt;</span>geronimo-atinject_1.0_spec<span
class="nt">&lt;/artifactId&gt;</span>
+    <span class="nt">&lt;version&gt;</span>1.0<span class="nt">&lt;/version&gt;</span>
+<span class="nt">&lt;/dependency&gt;</span>
+
+<span class="nt">&lt;dependency&gt;</span>
+    <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
+    <span class="nt">&lt;artifactId&gt;</span>geronimo-jcdi_2.0_spec<span
class="nt">&lt;/artifactId&gt;</span>
+    <span class="nt">&lt;version&gt;</span>1.0<span class="nt">&lt;/version&gt;</span>
+<span class="nt">&lt;/dependency&gt;</span>
+
+<span class="nt">&lt;dependency&gt;</span>
+    <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
+    <span class="nt">&lt;artifactId&gt;</span>geronimo-interceptor_1.2_spec<span
class="nt">&lt;/artifactId&gt;</span>
+    <span class="nt">&lt;version&gt;</span>1.0<span class="nt">&lt;/version&gt;</span>
+<span class="nt">&lt;/dependency&gt;</span>
+
+<span class="nt">&lt;dependency&gt;</span>
+    <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
+    <span class="nt">&lt;artifactId&gt;</span>geronimo-annotation_1.3_spec<span
class="nt">&lt;/artifactId&gt;</span>
+    <span class="nt">&lt;version&gt;</span>1.0<span class="nt">&lt;/version&gt;</span>
+<span class="nt">&lt;/dependency&gt;</span>
+</pre></div>
+
+
+<p>Note that you should set the seope of those dependencies to either <code>provided</code>
or <code>compile</code> depending on whether your environment already provide
them or not.</p>
+<h4 id="apis-version12">APIs for OWB-1.7.x<a class="headerlink" href="#apis-version12"
title="Permanent link">&para;</a></h4>
 <div class="codehilite"><pre><span class="nt">&lt;dependency&gt;</span>
     <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
     <span class="nt">&lt;artifactId&gt;</span>geronimo-atinject_1.0_spec<span
class="nt">&lt;/artifactId&gt;</span>
@@ -153,14 +202,12 @@ We will try to add complete lists of thi
     <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
     <span class="nt">&lt;artifactId&gt;</span>geronimo-interceptor_1.2_spec<span
class="nt">&lt;/artifactId&gt;</span>
     <span class="nt">&lt;version&gt;</span>1.0<span class="nt">&lt;/version&gt;</span>
-    <span class="nt">&lt;scope&gt;</span>compile<span class="nt">&lt;/scope&gt;</span>
 <span class="nt">&lt;/dependency&gt;</span>
 
 <span class="nt">&lt;dependency&gt;</span>
     <span class="nt">&lt;groupId&gt;</span>org.apache.geronimo.specs<span
class="nt">&lt;/groupId&gt;</span>
     <span class="nt">&lt;artifactId&gt;</span>geronimo-annotation_1.2_spec<span
class="nt">&lt;/artifactId&gt;</span>
     <span class="nt">&lt;version&gt;</span>1.0<span class="nt">&lt;/version&gt;</span>
-    <span class="nt">&lt;scope&gt;</span>compile<span class="nt">&lt;/scope&gt;</span>
 <span class="nt">&lt;/dependency&gt;</span>
 </pre></div>
 

Modified: websites/staging/openwebbeans/trunk/content/faq.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/faq.html (original)
+++ websites/staging/openwebbeans/trunk/content/faq.html Mon Jul 17 13:21:24 2017
@@ -81,42 +81,13 @@
 h2:hover > .headerlink, h3:hover > .headerlink, h1:hover > .headerlink, h6:hover
> .headerlink, h4:hover > .headerlink, h5:hover > .headerlink, dt:hover > .elementid-permalink
{ visibility: visible }</style>
 <h1 id="openwebbeans-faq">OpenWebBeans FAQ<a class="headerlink" href="#openwebbeans-faq"
title="Permanent link">&para;</a></h1>
 <ul>
-<li>
-<p><a href="#Does OWB differ from the CDI-1.0 specification">Does OWB differ
from the CDI-1.0 specification</a></p>
-</li>
-<li>
-<p>what is the default EL version used in OWB</p>
-</li>
+<li><a href="#Does OWB differ from the CDI-2.0 specification">Does OWB differ
from the CDI-2.0 specification</a></li>
+<li>what is the default EL version used in OWB</li>
 <li>how can I provide own plugins if there is a new spec part (e.g EL-3.0) I like to
support</li>
-<li>Do you have any support for CDI 1.1 (JSR-346)</li>
-<li>How can I contribute to OpenWebBeans</li>
-<li>
-<p>I found what could be a bug, how do I proceed</p>
-</li>
-<li>
-<p><a href="#Does OWB differ from the CDI-1.0 specification">Does OWB differ
from the CDI-1.0 specification</a></p>
-</li>
-<li>
-<p>what is the default EL version used in OWB</p>
-</li>
-<li>how can I provide own plugins if there is a new spec part (e.g EL-3.0) I like to
support</li>
-<li>Do you have any support for CDI 1.1 (JSR-346)</li>
-<li>How can I contribute to OpenWebBeans</li>
-<li>
-<p>I found what could be a bug, how do I proceed</p>
-</li>
-<li>
-<p><a href="#Does OWB differ from the CDI-1.0 specification">Does OWB differ
from the CDI-1.0 specification</a></p>
-</li>
-<li>
-<p>what is the default EL version used in OWB</p>
-</li>
-<li>how can I provide own plugins if there is a new spec part (e.g EL-3.0) I like to
support</li>
-<li>Do you have any support for CDI 1.1 (JSR-346)</li>
 <li>How can I contribute to OpenWebBeans</li>
 <li>I found what could be a bug, how do I proceed</li>
 </ul>
-<h3 id="does-owb-differ-from-the-cdi-10-specification">Does OWB differ from the CDI-1.0
specification<a class="headerlink" href="#does-owb-differ-from-the-cdi-10-specification"
title="Permanent link">&para;</a></h3>
+<h3 id="does-owb-differ-from-the-cdi-20-specification">Does OWB differ from the CDI-2.0
specification<a class="headerlink" href="#does-owb-differ-from-the-cdi-20-specification"
title="Permanent link">&para;</a></h3>
         </div>
 
         <hr>

Modified: websites/staging/openwebbeans/trunk/content/index.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/index.html (original)
+++ websites/staging/openwebbeans/trunk/content/index.html Mon Jul 17 13:21:24 2017
@@ -78,8 +78,8 @@
         <div class="col-md-10 col-lg-10 col-sm-10 col-xs-10">
             <p>
                 Apache OpenWebBeans delivers an implementation of the
-                <a href="http://jcp.org/en/jsr/detail?id=346">Contexts and Dependency
injection for Java EE</a> (CDI) 1.2 Specification (JSR346).<br/>
-                OpenWebBeans is TCK compliant and the latest version works on Java SE 7 or
later.
+                <a href="http://jcp.org/en/jsr/detail?id=346">Contexts and Dependency
injection for Java EE</a> (CDI) 2.0 Specification (JSR-365).<br/>
+                OpenWebBeans is TCK compliant and the latest version works on Java SE 8 or
later.
             </p>
             <p>
                 Apache OpenWebBeans is
@@ -104,8 +104,8 @@
     </div>
     <div class="col-md-6">
         <h2>Meecrowave</h2>
-        <p>Apache Meecrowave is a microprofile Server based on Apache OpenWebBeans,
Tomcat, CXF and Johnzon. 
-			In other words it contains all you need to run a JavaEE based Microservice from the command
line - and all that in only 9 MB!</p>
+        <p>Apache Meecrowave is a microprofile Server based on Apache OpenWebBeans,
Tomcat, CXF and Johnzon
+            In other words it contains all you need to run a JavaEE based Microservice from
the command line - and all that in only 9 MB!</p>
         <p><a class="btn btn-default" href="meecrowave/index.html#">View details
»</a></p>
     </div>
 </div>

Modified: websites/staging/openwebbeans/trunk/content/news.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/news.html (original)
+++ websites/staging/openwebbeans/trunk/content/news.html Mon Jul 17 13:21:24 2017
@@ -81,6 +81,7 @@
 h2:hover > .headerlink, h3:hover > .headerlink, h1:hover > .headerlink, h6:hover
> .headerlink, h4:hover > .headerlink, h5:hover > .headerlink, dt:hover > .elementid-permalink
{ visibility: visible }</style>
 <h1 id="news">News<a class="headerlink" href="#news" title="Permanent link">&para;</a></h1>
 <ul>
+<li>2017-07-16 OpenWebBeans-2.0.0 has been released - this is our first CDI-2.0 release!</li>
 <li>2017-07-11 Meecrowave-1.0.0 has been released</li>
 <li>2017-07-11 OpenWebBeans-1.7.4 has been released - this is a CDI-1.2 bugfix release</li>
 <li>2017-04-19 OpenWebBeans-1.7.3 has been released - this is a CDI-1.2 bugfix release</li>

Modified: websites/staging/openwebbeans/trunk/content/openwebbeans-impl.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/openwebbeans-impl.html (original)
+++ websites/staging/openwebbeans/trunk/content/openwebbeans-impl.html Mon Jul 17 13:21:24
2017
@@ -113,7 +113,8 @@ the newest version would have to drop su
 or be a hot mess with version checks and endless if - else cases between all the framework

 combinations. Naturally it would only get worse and worse over time. </p>
 <p>Glad we avoided all that and have the exact opposite result, the latest 
-OpenWebBeans still support JSF 1.2, EL-1.0, JSP, Tomcat 6 and so on. </p>
+OpenWebBeans still support JSF 2.0, EL-1.0, JSP, Tomcat 7 and so on.
+And you can just plug support for your own framework.</p>
 <h2 id="introduction-to-our-plugin-system">Introduction to our plugin system<a class="headerlink"
href="#introduction-to-our-plugin-system" title="Permanent link">&para;</a></h2>
 <p>The end users has to combine the core with their own mix of plugins and can include

 exactly what they want (including custom plugins) yet nothing they don't need. 

Modified: websites/staging/openwebbeans/trunk/content/openwebbeans-tomcat.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/openwebbeans-tomcat.html (original)
+++ websites/staging/openwebbeans/trunk/content/openwebbeans-tomcat.html Mon Jul 17 13:21:24
2017
@@ -79,20 +79,10 @@
   visibility: hidden;
 }
 h2:hover > .headerlink, h3:hover > .headerlink, h1:hover > .headerlink, h6:hover
> .headerlink, h4:hover > .headerlink, h5:hover > .headerlink, dt:hover > .elementid-permalink
{ visibility: visible }</style>
-<h1 id="openwebbeans-tomcat-6-7-and-8">OpenWebBeans Tomcat 6, 7 and 8<a class="headerlink"
href="#openwebbeans-tomcat-6-7-and-8" title="Permanent link">&para;</a></h1>
+<h1 id="openwebbeans-tomcat-7-8-85-and-9">OpenWebBeans Tomcat 7, 8, 8.5 and 9<a
class="headerlink" href="#openwebbeans-tomcat-7-8-85-and-9" title="Permanent link">&para;</a></h1>
 <p>Note: You also need other modules to run OpenWebBeans on Tomcat. 
 These Tomcat plugins only adds extra features like injection into Servlets and are not even
mandatory for running on Tomcat. For more information read <a href="http://openwebbeans.apache.org/owbsetup_ee.html">Getting
started</a>.</p>
-<h3 id="tomcat-6-module">Tomcat 6 Module<a class="headerlink" href="#tomcat-6-module"
title="Permanent link">&para;</a></h3>
-<div class="codehilite"><pre><span class="nt">&lt;dependency&gt;</span>
-    <span class="nt">&lt;groupId&gt;</span>org.apache.openwebbeans<span
class="nt">&lt;/groupId&gt;</span>
-    <span class="nt">&lt;artifactId&gt;</span>openwebbeans-tomcat6<span
class="nt">&lt;/artifactId&gt;</span>
-    <span class="nt">&lt;version&gt;</span><span class="cp">${</span><span
class="n">owb</span><span class="o">.</span><span class="n">version</span><span
class="cp">}</span><span class="nt">&lt;/version&gt;</span>
-    <span class="nt">&lt;scope&gt;</span>compile<span class="nt">&lt;/scope&gt;</span>
-<span class="nt">&lt;/dependency&gt;</span>
-</pre></div>
-
-
-<h3 id="tomcat-7-and-8">Tomcat 7 and 8<a class="headerlink" href="#tomcat-7-and-8"
title="Permanent link">&para;</a></h3>
+<h3 id="tomcat-7-and-above">Tomcat 7 and above<a class="headerlink" href="#tomcat-7-and-above"
title="Permanent link">&para;</a></h3>
 <div class="codehilite"><pre><span class="nt">&lt;dependency&gt;</span>
     <span class="nt">&lt;groupId&gt;</span>org.apache.openwebbeans<span
class="nt">&lt;/groupId&gt;</span>
     <span class="nt">&lt;artifactId&gt;</span>openwebbeans-tomcat7<span
class="nt">&lt;/artifactId&gt;</span>

Modified: websites/staging/openwebbeans/trunk/content/owb-eecontainers.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/owb-eecontainers.html (original)
+++ websites/staging/openwebbeans/trunk/content/owb-eecontainers.html Mon Jul 17 13:21:24
2017
@@ -87,6 +87,7 @@ h2:hover > .headerlink, h3:hover > .head
 <li>IBM WebSphere Application Server 8.0 and 8.5</li>
 <li>IBM WebSphere Application Server Liberty Profile 8.5</li>
 <li>SiwPas</li>
+<li>As part of various other Vendor offerings like SAP, etc</li>
 </ul>
         </div>
 

Modified: websites/staging/openwebbeans/trunk/content/owbsetup_ee.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/owbsetup_ee.html (original)
+++ websites/staging/openwebbeans/trunk/content/owbsetup_ee.html Mon Jul 17 13:21:24 2017
@@ -94,10 +94,10 @@ But since OpenWebBeans is modular you sh
 <h3 id="api-jars">API jars<a class="headerlink" href="#api-jars" title="Permanent
link">&para;</a></h3>
 <p>Several API bundles exists for java EE and they are mostly compatible with OpenWebBeans.
If you already include one of these you might not need any api jars. CDI and thus OpenWebBeans
depends on the following four apis:</p>
 <ul>
-<li><strong>CDI: <a href="/download.html#apis-version">geronimo-jcdi_1.1_spec.jar</a></strong></li>
+<li><strong>CDI: <a href="/download.html#apis-version">geronimo-jcdi_2.0_spec.jar</a></strong></li>
 <li><strong>AtInject: <a href="/download.html#apis-version">geronimo-atinject_1.0_spec.jar</a></strong></li>
 <li><strong>Interceptor: <a href="/download.html#apis-version">geronimo-interceptor_1.2_spec.jar</a></strong></li>
-<li><strong>Common Annotations: <a href="/download.html#apis-version">geronimo-annotation_1.2_spec.jar</a></strong></li>
+<li><strong>Common Annotations: <a href="/download.html#apis-version">geronimo-annotation_1.3_spec.jar</a></strong></li>
 </ul>
 <p>You will only reference these API:s in your own project. This way your project will
stay CDI vendor neutral. A typical use case would be to add all four of the above to your
parent-pom or your core module. </p>
 <h3 id="required-parts">Required<a class="headerlink" href="#required-parts" title="Permanent
link">&para;</a></h3>
@@ -112,7 +112,6 @@ But since OpenWebBeans is modular you sh
 <ul>
 <li><strong><a href="/download.html#plugins-version">openwebbeans-el22</a></strong></li>
 <li><strong><a href="/download.html#plugins-version">openwebbeans-tomcat7</a></strong></li>
-<li><strong><a href="/download.html#plugins-version">openwebbeans-tomcat6</a></strong></li>
 <li><strong><a href="/download.html#plugins-version">openwebbeans-jsf22</a></strong></li>
 </ul>
 <h3 id="when-to-use-respective-plugin">When to use respective plugin<a class="headerlink"
href="#when-to-use-respective-plugin" title="Permanent link">&para;</a></h3>
@@ -125,10 +124,11 @@ For JSF support add JSF plugin according
 <ul>
 <li>Java Server Faces 2.0 or later - <strong><a href="/download.html#plugins-version">openwebbeans-jsf22</a></strong></li>
 </ul>
-<p>If the project uses Tomcat 6 or Tomcat 7 you can add the respective plugin. This
is not required but enables injection in Servlets and Filters. Note that Tomcat7 should be
read as Tomcat7+ thus it works perfectly fine with Tomcat 8.</p>
+<p>If the project uses Tomcat 7 or above you can add the respective plugin.
+This is not required but enables injection in Servlets and Filters.
+Note that the tomcat7 plugin works perfectly fine with Tomcat 8, 8.5 and even Tomcat 9.</p>
 <ul>
-<li>Tomcat 6 - <strong><a href="/download.html#plugins-version">openwebbeans-tomcat6</a></strong></li>
-<li>Tomcat 7 / Tomcat 8 - <strong><a href="/download.html#plugins-version">openwebbeans-tomcat7</a></strong></li>
+<li>Tomcat 7 / Tomcat 8 / Tomcat 9 - <strong>[openwebbeans-tomcat7][11]</strong></li>
 </ul>
 <h3 id="configuring-owb">Bootstrapping OpenWebBeans<a class="headerlink" href="#configuring-owb"
title="Permanent link">&para;</a></h3>
 <p>Simply put the following listener in web.xml: </p>

Modified: websites/staging/openwebbeans/trunk/content/owbsetup_se.html
==============================================================================
--- websites/staging/openwebbeans/trunk/content/owbsetup_se.html (original)
+++ websites/staging/openwebbeans/trunk/content/owbsetup_se.html Mon Jul 17 13:21:24 2017
@@ -100,10 +100,10 @@ for the time being the existing plugins
 <p>You also need to add some spec API jars for the CDI, atinject and interceptors 
 specifications.</p>
 <ul>
-<li><strong><a href="/download.html#apis-version">geronimo-jcdi_1.0_spec.jar</a></strong></li>
+<li><strong><a href="/download.html#apis-version">geronimo-jcdi_2.0_spec.jar</a></strong></li>
 <li><strong><a href="/download.html#apis-version">geronimo-atinject_1.0_spec.jar</a></strong></li>
 <li><strong><a href="/download.html#apis-version">geronimo-interceptor_1.2_spec.jar</a></strong></li>
-<li><strong><a href="/download.html#apis-version">geronimo-annotation_1.2_spec.jar</a></strong></li>
+<li><strong><a href="/download.html#apis-version">geronimo-annotation_1.3_spec.jar</a></strong></li>
 </ul>
 <p>After you have added the jars described above to your project accordingly 
 to the download page and added them to your projects classpath.</p>



Mime
View raw message