openoffice-utenti-it mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valerio Messina <...@iol.it>
Subject Re: [utenti-it] settaggio dei mime-type con AOO 4.1.2 su Linux
Date Sun, 03 Jan 2016 22:27:20 GMT
On 03/01/2016 19:10, Valerio Messina wrote:
> I problemi che ho rilevato sono:
> 1) non si creano i links:
> openoffice4
> soffice # fa conflitto con Libreoffice e da errore
> in /usr/bin
>
> 2) non si copiano i files *.desktop da:
> /opt/openoffice4/share/xdg
> oppure
> en-US/DEBS/desktop-integration/usr/share/applications/
> a:
> /usr/share/applications
> per cui il sistema non conosce i file apribili con AOO
>
> 3) non si copiano le icone da:
> en-US/DEBS/desktop-integration/usr/share/icons/
> a:
> /usr/share/icons/

più l'altro problema segnalato solo nella prima mail:

4) nei file *.desktop forniti in:
openoffice4/share/xdg/
come binario da avviare è indicato Exec=openoffice4
Però "openoffice4" è un link che si dovrebbe creare in /usr/bin e che 
punta a:
openoffice4/program/soffice
Anche creadolo a mano con:
$ sudo ln -s /opt/openoffice4/program/soffice /usr/bin/openoffice4
lanciando "openoffice4" non va perché "soffice" è uno script che 
richiama il vero binario, e compone il nome del binario, prendendo il 
proprio e aggiungendo .bin
Quindi se avvio openoffice4/program/soffice trova il soffice.bin 
correttamente, mentre se avvio openoffice4 non trova l'inesistente 
openoffice4.bin e da errore.
Questo si riperquote anche sulle associazioni mine-type perché anche 
dopo aver risolto a mano il problema 2), AOO non si avvia nemmeno se 
reso il programma default per una certo tipo di file.
Creando un link:
openoffice4/program/openoffice4.bin
che punta a:
openoffice4/program/soffice.bin
si risolve anche questo.

Valerio


---------------------------------------------------------------------
To unsubscribe, e-mail: utenti-it-unsubscribe@openoffice.apache.org
For additional commands, e-mail: utenti-it-help@openoffice.apache.org


Mime
View raw message