openoffice-utenti-it mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Pescetti <pesce...@apache.org>
Subject Re: [utenti-it] Calc - problema con le date
Date Sat, 05 Oct 2013 12:56:00 GMT
Il 12/09/2013 Argasoft by Arnaldo Gaudenzi ha scritto:
> Ho una semplice funzione:
> =SE(E6<>"";DDE("soffice";O6;"Ft.F18");"")
> dove
> O6 contiene il nome del file
> Ft.F18 è una cella formattata come data (GG.MM.AAAA)
> La cella di destinazione ha lo stesso formato di Ft.F18 (GG.MM.AAAA)
> Perché il risultato visibile è 30.12.1899?

Ho provato a riprodurre il bug con la versione 4.0.1 appena uscita. Se 
formatto Ft.F18 con le impostazioni predefinite tutto funziona bene, o 
almeno cosi' pare; posso anche cambiare la data in Ft.F18 e le modifiche 
sono riportate nell'altro file. Se invece cambio il formato di Ft.F18 in 
GG.MM.AAAA e poi cambio la data, allora anch'io vedo il problema (in 
pratica non viene interpretata come data, ma come numero decimale, da 
cui il valore "0,xyz" e la conversione al 1899). Il formato della cella 
di destinazione invece non influisce in alcun modo. Prima di procedere 
alla segnalazione, puoi verificare se anche nel tuo caso il 
comportamento e' lo stesso?

Ciao,
   Andrea.


---------------------------------------------------------------------
Per cancellarsi: utenti-it-unsubscribe@openoffice.apache.org
Per informazioni: http://www.openoffice.org/it/
Per avviare una nuova discussione: utenti-it@openoffice.apache.org
Archivi: http://mail-archives.apache.org/mod_mbox/openoffice-utenti-it


Mime
View raw message