openoffice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From doris diosa <zorahpo...@gmail.com>
Subject Re: Unsubscribe please
Date Mon, 07 Apr 2014 21:34:06 GMT

Sorry but these posts are incoherent to me. 



Sent from Samsung tablet

-------- Original message --------
From japples <japples@europa.com> 
Date: 04/07/2014  3:18 PM  (GMT-06:00) 
To Brian Barker <b.m.barker@btinternet.com>,"OO users@openoffice.apache.org" <users@openoffice.apache.org>

Subject Re: Calc Formula Question 
 
I entered an "IF" formula that produced the error.  Statement of fact.

Not finding an easy answer in Help (opened under OpenOffice Calc, used 
"Find" to search the term "#name error" with result "no topics found") - 
I turned to the message board (can only see messages related to my 
question / comment)

Note: my question was a statement of fact
Note: another time the error happened was with a negative number - 
again, logically that negative number should have been calculated in the 
IF formula
Note: Contents did not contain info re: Calc error
Note:  I did not have an error 525 displayed so continued searching for 
the error I received
. . . "error 525 #name" may not be the same as "#name"

    Note: definition is "An identifier could not be evaluated, for
    example, no valid reference, no valid domain name, no column/row
    label, no macro, incorrect decimal divider, add-in not found."

Note: The IF Formula I was trying to use worked in Excel, Quatto, and 
Lotus - just had a bit of adjustment changing to Calc - is this the 
point you assumed I overlooked? 

Now for the definition in Calc help:  Identifier - refers to what?; had 
a valid reference, did not require a domain name, had valid column / row 
labels, no macro with except of IF function were involved, no division 
was requested, no add-in other than the sum in referenced cells.

When I use Help, I expect an intuitive document designed for the casual 
/ new user.  Does that help clarify why I didn't find the error number 
(which I did not receive) and you so kindly pointed out?

No worries . . . I figured it out.
Jack





Brian Barker wrote:
> At 10:25 07/04/2014 -0700, you wrote:
>> One of the cells included in the formula = 0;  Logically, if a cell 
>> is 0, the formula would over look it.
> That's certainly untrue!  Zero is a perfectly valid value, of course, 
> and different formulae will handle zero values in appropriate ways - 
> which may include throwing an error.  And it's worth knowing that an 
> empty cell, a cell with a zero value in it, and a cell with one or 
> more blank characters in it (which will *look* empty) may all be 
> handled differently.
>
> But no, in any case, you are missing the point: you will not get the 
> #NAME? error simply from something such as a zero value addressed in a 
> formula.  This error occurs only if there is a name that cannot be 
> resolved.  You must either have typed nonsense or - as I said before- 
> probably mistyped something.  You could have misspelled the name of a 
> sheet or range or function, or you could perhaps have confused the 
> syntax of an expression and left what looks to Calc like an unknown 
> name.  You wouldn't get this error merely from a zero argument.
>
>> I did not find a reference in Help.
>
> If I open the Help from within Calc, the second main entry in the 
> Index list is "#NAME error message"!  If you look up "error", you will 
> quickly get to "error codes;list of", and you will see that error 525 
> is represented not as "Err:525" but as "#NAME?".  You will see there 
> that it's all about identifiers, not zero values.
>
> Brian Barker
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message