openoffice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Singhal, Ankur" <asing...@ptc.com>
Subject Issue with dmake of AOO-3.4.1 for the module "stlport"
Date Thu, 18 Jul 2013 13:24:10 GMT
Hi Team,

I need all your help in resolving my issues, while setting up my machine(Windows 7) for development
on OpenOffice.

Steps I have followed to build (http://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Windows_7)

1)      I have downloaded source code directly from http://www.openoffice.org/download/other.html#tested-sdk
.

2)      Did my configure using the below paths:

--with-cl-home="/cygdrive/f/Microsoft Visual Studio 9.0/VC" \

--with-mspdb-path="/cygdrive/f/Microsoft Visual Studio 9.0/Common7/IDE" \

--with-frame-home="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0" \

--with-psdk-home="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0" \

--with-midl-path="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v7.0/Bin" \

--with-asm-home="/cygdrive/f/Microsoft Visual Studio 9.0/VC/bin" \

--with-csc-path="/cygdrive/c/WINDOWS/Microsoft.NET/Framework/v3.5" \

--with-jdk-home="/cygdrive/c/Java64/jdk1.6.0_35"                    \

--with-ant-home="/cygdrive/c/apache-ant-1.9.2" \

--with-dmake-url=http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2 \

--with-epm-url=http://ftp.easysw.com/pub/epm/3.7/epm-3.7-source.tar.gz \

--disable-directx \

--enable-dbgutil \

--enable-pch \

--disable-atl \

--disable-activex \

--disable-binfilter \

--without-junit

3)      Bootstrap ran properly.

4)      dmake is failing to build "stlport" module with the error "File to Patch:"


Options that I have tried:

1)      Resolving the conflicts by going to separate files like VC7.mak, _monetary.c, _num_put.c,
_time_facets.c, _list.h.

After resolving conflicts it gives error as below:

.\streambuf.cpp(43) : error C2511: 'stlp_std::basic_streambuf<_CharT,_Traits>::basic_streambuf(FILE
*,FILE *)' : overloaded member function not found in 'stlp_std::basic_streambuf<_CharT,_Traits>'

2)      I tried moving from Visual Studio 2008 to Visual Studio 2010.

It starts giving other error about a file named "exception" under Visual Studio. I believe
Visual Studio 2010 is not supported by OpenOffice.

3)      I tried replacing module "stlport-4.5" with "stlport-5.2.1" and compiling  the module.
(With Visual Studio 2008)

But I am still facing the same issue.

.\streambuf.cpp(43) : error C2511: 'stlp_std::basic_streambuf<_CharT,_Traits>::basic_streambuf(FILE
*,FILE *)' : overloaded member function not found in 'stlp_std::basic_streambuf<_CharT,_Traits>'

It would be very helpful if someone can help me in resolving this issue or if someone have
faced the same issue earlier.

I believe this is not an issue related to code but a configuration issue.

Thanks in Advance,
Ankur Singhal





Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message