openoffice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johnny Rosenberg <gurus.knu...@gmail.com>
Subject Re: [libreoffice-users] ”Artifacts” in OpenOffice and LibreOffice
Date Sun, 12 May 2013 19:43:36 GMT
2013/5/11 Andrew Douglas Pitonyak <andrew@pitonyak.org>:
>
> I have had subtle redraw issues with OO off and on, and I always blamed it
> on an interaction between applications and the video drivers. Realize that I
> use nVidia video cards on 64-bit Fedora using the proprietary video drivers.
> What I saw was not remotely as bad. Admittedly, when I tried out the latest
> dev build, it was totally unusable (of course, the single tester was unable
> to reproduce on Windows 7).
>
> see https://issues.apache.org/ooo/show_bug.cgi?id=122214
>
> Are you able to do a test and change your video driver say between the free
> and not free driver to see if there is a change (I do not use Ubuntu so I
> don't have a good handle on what drivers are available or how).
>
> I used to have exactly the same problem in QT, and it was very bad. I was
> able to avoid the problem with QT Creator by starting it using
>
> -graphicssystem raster
>
> Not that I expect this to help you. I did notice that it still has some
> rendering issues that appeared in the latest versions (I believe it is
> related to an over-lay issue when you edit a field.... that assumption
> allowed me to fix it in the software that I write, but I did not jump into
> the QT code base).
>
> I have seen strange redraw issues so long in OO that correcting for it is
> almost automatic in my brain (scroll screen up then down to clear) so I
> cannot even say if I still see the problem. I think I do, but it is for sure
> not as bad is it used to be for me.
>
> I know, that I have rambled on and on.... I will summarize in saying
>
> 1. I have never seen it so bad
> 2. I have seen screen corruption
> 3. You may avoid some of it based on the video driver
>
> If I had it that bad on my Fedora system, I would likely change my desktop
> on login to see if it helped. With Fedora, I can easily jump between Gnome
> and KDE (as one example). I would also try jumping between the two different
> drivers available to see how that helped as well. Sadly, the "free" driver
> is poor with respect to 3D stuff.

Thanks for your input, and also thanks to all of you who replied.

I did some more tests and I found that it seems to be a problem
related to the fact that my graphics card is blacklisted for use with
Unity 3D.
First I installed KDE, just to see what happens. I wasn't sure what
package to install, so I installed kde-full, which maybe was a bit
overkill…
I logged out and then in to KDE, configured the driver to use both
screens, then I opened a spreadsheet. Oddly enough, it tried to open
the file with an archive manager, so I had to manually tell it to open
with OpenOffice. I then opened the Basic IDE window and I found no
problems what so ever, except that I don't like KDE, but that's
another question…

I didn't try the free driver, but maybe I will later.

Right now I am logged in to Unity 2D and that also works flawlessly. I
don't like Unity 2D either, though. I miss some Compiz effects, among
other things… Maybe I just have to live with it until I buy another
computer with a non-blacklisted graphics card…


Johnny Rosenberg

>
>
>
> On 05/11/2013 08:52 AM, Johnny Rosenberg wrote:
>>
>> I have had this problem for quite some time now (months if not years)
>> in LibreOffice and OpenOffice. The problems are maybe a little bit
>> worse in LibreOffice, but I didn't exactly measure it…
>>
>> It looks like a graphics card problem, but why are nothing else
>> affected? It only happens to OpenOffice and LibreOffice. I tested a
>> few versions and it seems to not matter. The screenshots are taken
>> with Apache OpenOffice 3.4.1 and I saw the same thing in LibreOffice
>> 3.5, 3.6 and 4.0. I think this also happened with earlier LibreOffice
>> versions, like 3.4 and 3.3. I didn't use OpenOffice since 3.2 (except
>> 3.4.1, which I use these days), and I don't even remember what it
>> looked like.
>>
>> Here's a screenshot with Apache OpenOffice Calc 3.4.1. I added some
>> arrows pointing at the problem areas:
>> http://ubuntuone.com/0wvqcaN38PC5835t4uJVPv
>>
>> The worst thing is when I try to use the Basic IDE, take a look at
>> this. Very hard to write and edit code when it looks like this:
>> http://ubuntuone.com/4HRPQMpblZT97UxHq5ggzO
>>
>> My operating system is Ubuntu 12.04 and the more stuff I run at the
>> same time, the worse will it look.
>>
>> My graphics card is the nVidia GeForce Go 7300, which is blacklisted
>> for use with the Unity 3D desktop, so that may be what's causing this
>> problem, but still it ONLY happens to LibreOffice and OpenOffice.
>>
>> One thought that I have is that LibreOffice and OpenOffice are not GTK
>> applications (I think – are they?), but on the other hand, neither is
>> my web browser (Opera), and I don't have these problems with it.
>>
>> Both LibreOffice and OpenOffice.org were installed with the official
>> deb files. The LibreOffice version that came with Ubuntu 12.04 was
>> carefully removed before installing what I have now.
>>
>> Thoughts? Anyone else saw this?
>>
>> Packard Bell Easy Note MX66 laptop, made in November 2006.
>> 2.0 GiB RAM, Genuine Intel® CPU T2050 @ 1.60GHz × 2.
>>
>> Ubuntu 12.04 LTS (32 bits)
>> Kernel: Linux 3.2.0-41-generic-pae
>>
>> nVIDIA Driver Version: 304.88
>>
>
> --
> Andrew Pitonyak
> My Macro Document: http://www.pitonyak.org/AndrewMacro.odt
> Info:  http://www.pitonyak.org/oo.php
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-help@openoffice.apache.org


Mime
View raw message