openoffice-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry Evans <cppljev...@suddenlink.net>
Subject Re: calc BeanShell script save gives "error saving script" window.
Date Mon, 04 Mar 2013 19:18:14 GMT
On 03/04/13 13:05, Larry Evans wrote:
> On 03/04/13 12:33, Ariel Constenla-Haile wrote:
>> On Mon, Mar 04, 2013 at 09:15:30AM -0600, Larry Evans wrote:
>>> And after enabling macros, got window entitled "OpenOffice.org error"
>>> with body
>>> contains yellow triangle with ! in middle and text:
>>>
>>>   A Scripting Framework error occurred while running the BeanShell
>>>   script Library1.Macro1.bsh
>>>
>>>   Message: The scripting language BeanShell is not supported.
>>>
>>> What should I do now?
>>>
>>> Again, thanks for the help, Ariel.
>> My mistake, I took the jars from the build I work with (to be 4.0), not
>> 3.4.1. These are the proper JARs from 3.4.1: 
>>
>> http://people.apache.org/~arielch/api/class_3.4.1.tar.gz
>>
>>
>> Regards
> Thanks Ariel.  I downloaded
>
> class_3.4.1.tar.gz
>
> unzipped and untarred and then copied all the jars to the classes directory
> which now shows:
>
> /home/evansl/download/OpenOffice/r1372282/Apache_OpenOffice_incubating_3.4.1_Linux_x86-64_install-arc_en-US/openoffice.org/basis3.4/program/classes:
>   total used in directory 10132 available 54240108
> C -rw-r--r--  1 evansl evansl  371657 Mar  4 12:08 bsh.jar
> C -rw-r--r--  1 evansl evansl   16258 Mar  4 12:03 ScriptProviderForJavaScript.jar
> C -rw-r--r--  1 evansl evansl   11684 Mar  4 12:03 ScriptProviderForJava.jar
> C -rw-r--r--  1 evansl evansl   22500 Mar  4 12:03 ScriptProviderForBeanShell.jar
> C -rw-r--r--  1 evansl evansl   94774 Mar  4 12:03 ScriptFramework.jar
>
> I then started scalc, as before:
>
> ~/download/OpenOffice/r1372282/Apache_OpenOffice_incubating_3.4.1_Linux_x86-64_install-arc_en-US/openoffice.org3/program
$ ./scalc BeanShell.ods &
> [sh<1>] 6945
> ~/download/OpenOffice/r1372282/Apache_OpenOffice_incubating_3.4.1_Linux_x86-64_install-arc_en-US/openoffice.org3/program
$
>
> I enabled the macros; however, I'm still getting the same error message that I mentioned
in my previous post :(
>
> Should I maybe set the class path to:
>
> home/evansl/download/OpenOffice/r1372282/Apache_OpenOffice_incubating_3.4.1_Linux_x86-64_install-arc_en-US/openoffice.org/basis3.4/program/classes
>
> somewhere?
>
> TIA.
>
>
OOPS.  I killed the QuickStart and then did the same command line
invocation, and now the error message
doesn't appear.

That's kinda unintuitive :(

Anyway,  I can now run the macro without problem.

Thanks for the help, Ariel.

-regards,
Larry


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-help@openoffice.apache.org


Mime
View raw message