openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "technik_div@jrsch.de" <technik_...@jrsch.de>
Subject Re: Wie Vorigen Wert in Tabelle ermitteln?
Date Fri, 08 Dec 2017 15:50:41 GMT
Hallo,

hier noch mal die Tabelle

#1#A##0#Err#Err
#2#B##1#A#NV
#3#A#1#1#A#1
#4#C####NV
#5#B#2#2#B#2
#6#A#3#2#B#3
#7#A#3#3#A#3
#8#B#2#5#B#2
#9#A#1#7#A#
#10#C#NV#NV#NV#NV
#11#A#1#10#C#1
#12#B#2#10#C#2
#13#A#7#5#B#7
#14#C#4#9#A#4
#15#B#8#6#A#8
#16#A#1#14#C#1







Ich hoffe das ist deutlicher.
Horst
Am 08.12.2017 um 13:17 schrieb technik_div@jrsch.de:
> Hallo,
>
> ich habe folgendes Problem:
>
> eine Tabelle wie z.B.
>
> 1
>     A
>
>
>     NV oder 0
> 2
>     B
>
>
>     NV oder 0
> 3
>     A
>
>     1
>     1
> 4
>     C
>
>
>     NV oder 0
> 5
>     B
>
>     2
>     2
> 6
>     A
>     =??
>     3
>     3
> 7
>     A
>
>     3
>     6
> 8
>     B
>
>     22
>     5
> 9
>     A
>     =VERGLEICH(B9;VERSCHIEBUNG($B$1;0;0;A9-1);-1)
>     1
>     7
> 10
>     C
>     =VERGLEICH(B10;VERSCHIEBUNG($B$1;0;0;A10-1);-1)
>     5
>     4
> 11
>     A
>
>
>     9
> 12
>     B
>
>
>     5
>
> In Spalte C soll jetzt eine Formel, die mir die Zeilennummer der 
> vorheringen Zeile mit dem gleichen Eintrag wie in Spalte B ist. D.H. 
> den vorherigen Eintrag, der der gleiche ist wie in Spalte B (In B6 
> steht A also soll in C6 die 3 für die Zeile 3 stehen, wo das Element 
> vorher in der Liste steht. Also wie in Spalte D(differenz) oder E 
> (Zeilennummer).
>
> Hoffentlich war das verständlich.
>
> Bei der Ermittlung von Nachfolgenden Werten (ähnliches Problem) habe 
> ich mit Verschiebung um entsprechende Zeilen gute Ergebnisse bekommen. 
> Das geht aber wohl nicht Rückwärts.
>
> Ich vrsuchte =VERGLEICH(B10;VERSCHIEBUNG($B$1;0;0;A10-1);-1)
>
> Ich habe nicht verschoben, sondern nur eine Bereichshöhe angegeben und 
> dann Rückwärts gesucht mit -1. Nur ist der Bereich nicht alphabetisch 
> sortiert.
>
> Bis Nr 9 gibt es richtige ERgebnisse. Ab Spalte 10 wird es falsch.
>
> 1. Warum?
>
> 2. Wie kann man das Problem lösen?
>
>
> Horst
>
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message