openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "technik_div@jrsch.de" <technik_...@jrsch.de>
Subject Wie Vorigen Wert in Tabelle ermitteln?
Date Fri, 08 Dec 2017 12:17:39 GMT
Hallo,

ich habe folgendes Problem:

eine Tabelle wie z.B.

1
	A
	
	
	NV oder 0
2
	B
	
	
	NV oder 0
3
	A
	
	1
	1
4
	C
	
	
	NV oder 0
5
	B
	
	2
	2
6
	A
	=??
	3
	3
7
	A
	
	3
	6
8
	B
	
	22
	5
9
	A
	=VERGLEICH(B9;VERSCHIEBUNG($B$1;0;0;A9-1);-1)
	1
	7
10
	C
	=VERGLEICH(B10;VERSCHIEBUNG($B$1;0;0;A10-1);-1)
	5
	4
11
	A
	
	
	9
12
	B
	
	
	5

In Spalte C soll jetzt eine Formel, die mir die Zeilennummer der 
vorheringen Zeile mit dem gleichen Eintrag wie in Spalte B ist. D.H. den 
vorherigen Eintrag, der der gleiche ist wie in Spalte B (In B6 steht A 
also soll in C6 die 3 für die Zeile 3 stehen, wo das Element vorher in 
der Liste steht. Also wie in Spalte D(differenz) oder E (Zeilennummer).

Hoffentlich war das verständlich.

Bei der Ermittlung von Nachfolgenden Werten (ähnliches Problem) habe ich 
mit Verschiebung um entsprechende Zeilen gute Ergebnisse bekommen. Das 
geht aber wohl nicht Rückwärts.

Ich vrsuchte =VERGLEICH(B10;VERSCHIEBUNG($B$1;0;0;A10-1);-1)

Ich habe nicht verschoben, sondern nur eine Bereichshöhe angegeben und 
dann Rückwärts gesucht mit -1. Nur ist der Bereich nicht alphabetisch 
sortiert.

Bis Nr 9 gibt es richtige ERgebnisse. Ab Spalte 10 wird es falsch.

1. Warum?

2. Wie kann man das Problem lösen?


Horst



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message