openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wolfgang Jäth <jawo.ml.hams...@arcor.de>
Subject Re: Open Office Calc 4.1.3
Date Sun, 16 Apr 2017 14:56:02 GMT
Am 15.04.2017 um 23:15 schrieb Michael Grimm:
> 
> ich habe eine tagesbezogene Erlösstatistik nach Kunden erstellt. Aus dieser
> soll eine Summenliste nach Kunden und Monaten gefüttert werden. Für das
> aktuelle Jahr 2017 funktioniert das.
> 
> Dies ist z.B. die Funktion, um den Januar 2017 für einen Kunden zu
> saldieren.
> 
> =SUMMEWENNS(Unterrichtstage_2016_.$J$4:$J$402;Unterrichtstage_2016_.$D$4:$D$402;A5;Unterrichtstage_2016_.$B$4:$B$402;"<=31.Jan")

Hmm; fehlt da nicht ein Parameter? Der erste Datensatz besteht aus den
drei Parametern:

Unterrichtstage_2016_.$J$4:$J$402;
Unterrichtstage_2016_.$D$4:$D$402;
A5;

Der zweite aber nur noch aus 2 Parametern:

Unterrichtstage_2016_.$B$4:$B$402;
"<=31.Jan"

> Wenn ich jetzt diese Summenliste für 2016 erstellen will, muss ich statt
> 31.Jan was angeben, damit ein Vergleich auf den 31.01.2016 erfolgt?

prinzipiell den 31 Januar 2016.

Aber Du musst Dir bewusst sein, dass auch Datums- und Zeitangaben intern
einfach durch Zahlwerte repräsentiert werden (genau genommen durch die
Anzahl der Tage seit dem 30.12.1899; und Uhrzeiten sind Bruchteile von
ganzen Tagen). wenn Du also auf den 31. Januar 2016 vergleichst,
vergleichst Du genau genommen auf den 31. Januar 2016 00:00; sollte es
bei dem betreffenden Wert auch einen Uhrzeitanteil geben, also z. B. 31.
Januar 2016 10:03:27 o. ä., ist das natürlich größer. Daher würde ich
Dir empfehlen, lieber auf "kleiner 1.2." zu vergleichen.

> ich habe versuchsweise das Datum 31.01.2016 in eine Zelle gepackt und statt
> 31. Jan die Zelle angegeben. Da wird aber nichts saldiert.
> Was kann ich tun?

Erstens der Formel korrekte Parameter spendieren; und zweitens verlangt
der dritte Parameter einen String; wenn Du eine Zahl als Vergleichswert
verwenden willst, musst Du diesen also zuerst zusammen mit dem
Vergleichoprator in einen String umwandeln, z. B. so

| "<="&A1

o. ä.

Wolfgang
-- 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message