openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Grimm <mg.loesun...@gmail.com>
Subject Re: Open Office Calc 4.1.3
Date Sun, 16 Apr 2017 18:57:03 GMT
Lieber Wolfgang,

danke für deine Antwort. Zu deiner Feststellung, dass ein Parameter fehlt,
gehe ich davon aus, dass der Aufbau so aussieht:

=SUMMWENNS(Summenbereich; Kriterienbereich1; Kriterium1; Kriteriumbereich
2; Kriterium 2)

Wenn das so ist, dann fehlt nach meinem Dafürhalten kein Parameter.

In der Zwischenzeit habe ich mir so beholfen. Ich habe in der
tagesbezogenen Erlösliste jeweils aus dem Datum den Monat separiert und
jeweils dem Datensatz angefügt. nun vergleiche ich nur noch auf den Monat
und es klappt und ist damit auch jahresunabhängig.

=SUMMEWENNS(J338:J344;B338:B344;N333)

Was muss ich tun, wenn ich gegen eine Zelle (das Kriterium / 3. Parameter)
auf kleiner vergleichen will, also < N333 ? wenn ich das so angebe, gibt es
einen Fehler. Wenn ich angebe ;"<"N333), bekomme ich auch einen Fehler.

Lieber Horst,

auch ich danke dir für deine Antwort.

Zu deinen Fragen: A5 ist der aktuelle Kunde der Kundenspalte. In B stehen
die Daten der Leistungserbringung. Angezeigt wird z.B. 1. Dez, intern aber
abgebildet 1.12.2016. ich habe für 2016 und 2017 eine eigene Datei. 2017
gelingt der Vergleich mit z.B. 1. Dez, weil automatisch 2017 intern
angefügt ist. Das ganze funktioniert aber nicht für 2016. Auch hier wird an
dem Feld 1.12. das Jahr 2017 angefügt. So weit ging auch meine Erkenntnis.
Ich tue mich allerdings noch schwer mit der Angabe der Vergleichoperatoren.

Herzliche Grüße


Michael Grimm
Habichtweg 21
42115 Wuppertal
Lehrer der Altenpflege
Beratung und Coaching
ILP - Integrierte Lösungsorientierte Psychologie
& Persönlichkeitsentwicklung

Telefon  +49202 / 31955078
mobil     +49176 / 28888067
mg.loesungen@gmail.com

Am 16. April 2017 um 18:52 schrieb Horst <technik_div@jrsch.de>:

> Hallo,
> Also ich verstehe das Ganze nicht so.  Was steht in den Spalten, in A5
> usw.?
> Am besten reduzierst du eine Testdatei auf das notwendigste. Wenn sich das
> Problem dann nicht schon erledigt (passiert mir meistens :-)) und gib die
> Adresse hier an.
>
> Komisch kommt mir die Abfrage
>
> "<=31.Jan"
>
> vor. Da fehlt das Jahr. wäre interessant was in Spalte B steht.
>
> Außerdem ist der Tabellenname nicht unbedingt sinnvoll. Du musst für jedes
> Jahr eine neue Tabelle einrichten.
>
> Horst
>
>
> Am 15.04.2017 um 23:15 schrieb Michael Grimm:
>
>> Liebe Mitanwender,
>>
>> ich habe eine tagesbezogene Erlösstatistik nach Kunden erstellt. Aus
>> dieser
>> soll eine Summenliste nach Kunden und Monaten gefüttert werden. Für das
>> aktuelle Jahr 2017 funktioniert das.
>>
>> Dies ist z.B. die Funktion, um den Januar 2017 für einen Kunden zu
>> saldieren.
>>
>> =SUMMEWENNS(Unterrichtstage_2016_.$J$4:$J$402;Unterrichtstag
>> e_2016_.$D$4:$D$402;A5;Unterrichtstage_2016_.$B$4:$B$402;"<=31.Jan")
>>
>>
>> Wenn ich jetzt diese Summenliste für 2016 erstellen will, muss ich statt
>> 31.Jan was angeben, damit ein Vergleich auf den 31.01.2016 erfolgt?
>>
>> ich habe versuchsweise das Datum 31.01.2016 in eine Zelle gepackt und
>> statt
>> 31. Jan die Zelle angegeben. Da wird aber nichts saldiert.
>> Was kann ich tun?
>>
>> Vielen Dank schon mal für die Unterstützung.
>>
>>
>> Michael Grimm
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: users-de-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message