openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Semmel <sem...@gmx.ch>
Subject Re: Verweise in Tabellen
Date Sat, 14 Nov 2015 11:32:26 GMT

Moin Wolfgang,


Wolfgang Jäth schrieb am 14.11.2015 um 08:25:
> Am 13.11.2015 um 13:19 schrieb Semmel:
>> Die genutzte Formel in E20 [=SVERWEIS(C20;A5:H16;1)] oder auch
>> [=SVERWEIS(MAX(B5:H16);A5:H16;1)] ergibt die Zahl "42339" (Zelle als
>> "Zahl" formatiert) bzw. "Dezember", wenn die Zelle als "MMMM" formatiert
>> wird (siehe Zelle F20).
> Das kann nicht klappen. SVERWEIS sucht *immer* in der *ersten* Spalte
> der Matrix nach dem Suchkriterium. Dort stehen aber die /Monate/. Und da

genau da lag mein Fehler. Zum Zeitpunkt meiner Bemühungen war mein Kopf 
wohl mit ganz anderen Dingen soooo voll, dass ich über meinen Klopfer 
erst "gestolpert" war, als ich Alois' Lösung gesehen hatte. :)



> [...]
> eine einspaltige (oder einzeilige) Suchmatrix. Du brauchst also auf alle
> Fälle jeweils eine Hilfsspalte und eine Hilfszeile), in der Du die
> Suchmatrix auf jeweils nur *eine* Dimension 'zusammenfalten' kannst.
> Also in z. B. J5 (und die ganze J-Spalte soweit nötig) die Formel
> "=MAX(B5:H5)" und in B5 usw. die Formel "=MAX(B5:B17)".
>
> Dann kannst Du mit "=VERWEIS(MAX(J5:J17);J5:J16;A5:A16)" (bzw.
Ja, das ist dann schon klar und auch kein Problem mehr.



> BTW, FYI: Es gäbe durchaus auch eine Möglichkeit, /ohne/ Hilfsspalten
> aus zu kommen, aber das würde das Benutzen von Matrixfunktionen bedeuten
> (die im Prinzip das gleiche machen, nämlich aus der zweidimensionalen
> Matrix eine eindimensionale, und dieses Zwischenergebnis dann weiter
> verwursteln), und eine derart komplizierte Formel ergeben, dass ich Dir
> wirklich davon abraten möchte.
Igitt, igitt. Nein, je einfacher eine Lösung, desto besser.

Auch dir: vielen Dank für dein Bemühen und deine Hinweise.

Ein schönes Wochenende + liebe Grüße, Peter.


-- 
Es war einmal ein Muselmann,
Der trank sich einen Dusel an,
Er rief dann stets das Muselweib,
Wo es denn mit dem Fusel bleib'
(gekürzt, Original vom Heinz Erhard)



---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message