openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alois Klotz <alois.kl...@salzburg.at>
Subject Re: Verweise in Tabellen
Date Fri, 13 Nov 2015 19:43:21 GMT
Hallo Peter,
hier ist ein Vorschlag zur Lösung:
https://dl.dropboxusercontent.com/u/3483911/LO-divers/Handelsvolumen_V1.1-24.ods

Ich habe waagrecht und senkrecht 2 Hilfszeilen bzw. -spalten mit den 
Maximalwerten und den Monaten bzw. Jahren angelegt und damit kann man 
ohne Probleme mit wverweis und sverweis Monat und Jahr herausbekommen.
MfG Alois

-- 
www.easy4me.info

Semmel schrieb am 13.11.2015 um 13:19:
>
> Moin *.*,
>
> ich muss noch einmal nerven, da ich ein Verständnis- oder 
> Umsetzungsproblem mit SVERWEIS habe.
> Zum besseren Verständnis eine Tabellendarstellung unter: 
> http://www.file-upload.net/download-11039857/Verweise.JPG.html
>
> In der Tabelle stehen in der Zeile 4 verschiedene Jahre und in der 
> Spalte A (A5:A16) verschiedene Monate (01.01.2015 bis 01.12.2015 - mit 
> der Zellenformatierung "MMMM", so dass nur die Monate ausgegeben werden).
> Innerhalb der Matrix B5:H16 stehen verschiedene Werte.
>
> In der Zelle C20 wird der höchste Wert der Matrix ermittelt und ich 
> möchte nun in Zelle E20 (bzw. E21) wissen, wann genau (Monat und Jahr) 
> dieser Wert angefallen ist.
>
> Die genutzte Formel in E20 [=SVERWEIS(C20;A5:H16;1)] oder auch 
> [=SVERWEIS(MAX(B5:H16);A5:H16;1)] ergibt die Zahl "42339" (Zelle als 
> "Zahl" formatiert) bzw. "Dezember", wenn die Zelle als "MMMM" 
> formatiert wird (siehe Zelle F20). Ich kann in Zelle E20 auch die 
> Formel [=MONAT(SVERWEIS(C20;A5:H16;1))] bzw. 
> [=MONAT(SVERWEIS(MAX(B5:H16);A5:H16;1))] verwenden, dann ist das 
> Ergebnis "12", was ebenso dem Dezember entspricht.
> Die in Zelle E21 genutzte Formel [=WVERWEIS(C20;B4:H16;1)] ergibt "2011".
>
> Beides (Monat und Jahr) sind aber ja nun ganz offensichtlich falsch, 
> da der höchste Wert innerhalb der Matrix in Zelle E5 steht und damit 
> die korrekte Zuordnung "01/ 2008" bzw. "Januar 2008" lauten müsste. In 
> beiden Fällen "finden" SVERWEIS bzw. WVERWEIS aber die jeweils letzte 
> Zeile bzw. die letzte Spalte der Matrix, was darauf schließen lässt, 
> dass der korrekte Wert nicht gefunden wird. Kann das sein???
> In der Zelle E5 steht die Zahl "233275,82" - lediglich formatiert mit 
> zwei Nachkommastellen und "BLAU" und sie hat keine weiteren 
> Nachkommastellen. Exakt dieser Wert wird durch [=MAX(B5:H16)] in die 
> Zelle C20 übertragen. Weshalb also sollte der Wert mit SVERWEIS oder 
> WVERWEIS nicht gefunden werden?
> An der nicht angegeben Sortierfolge kann es doch wohl nicht liegen, da 
> die Werte in der Spalte 1 (Spalte A) doch sortiert sind !?!?
> Oder liegt es an den Leerzellen? (Kann aber eigentlich[?] auch nicht 
> sein).
>
> Sofern jemand die Tabelle selbst haben möchte: 
> http://www.file-upload.net/download-11039984/Handelsvolumen_V1.1-24.ods.html
>
> Ich kriege noch die Krise ... ;)
>
> Liebe Grüße und für jede Hilfe dankbar, Peter.
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message