openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Semmel <sem...@gmx.ch>
Subject Re: Fehlerabfrage in CALC mit "WENN-ODER"
Date Thu, 12 Nov 2015 09:02:38 GMT

Moin Schulze,

wie findest du diese Anrede? Nicht so gut? Dann solltest du zukünftig 
vielleicht auch Peter zu mir sagen.  :)

Dein Problem des nicht wirklich Nachvollziehen-Könnens mit einer relativ 
kurzen Schilderung, kenne ich nur zu gut. Und ich hätte die Datei nach 
Deiner Bitte heute auch auf einem fremden Server hinterlegt, wenn nicht 
auch Wolfgang schon eine Lösung angeboten hätte.

Und weiter kann man die Formeln ja praktisch kaum noch 
auseinanderziehen. Ferner funktionieren beide Teilabfragen ja auch - nur 
eben unter der Bedingung, dass das gesuchte Datum auch vorhanden ist. 
Ist das aber nicht vorhanden, gibt es ein "#NV", das ich dann mit der 
Fehlerabfrage unterbinden wollte.

Mir war dabei nur nicht klar (bzw. war ich der irrigen Annahme), dass 
ein "ODER" mehr oder minder auf jede der Bedingungen reagiert. D.h. ich 
dachte: ist nur eine Bedingung WAHR, dann "x", sonst "y" *und* sind 
beide Bedingungen WAHR, dann ebenfalls "x", sonst "y".
Mir war dabei nicht bewusst, dass eine ODER-Abfrage in Calc einem "XOR" 
(wie ich es aus Programmiersprachen kenne) arbeitet. Da lag mein Denkfehler.

Dennoch: herzlichen Dank für Deine Bemühungen, Horst.  ;)))

Liebe Grüße, Peter.


technik schrieb am 11.11.2015 um 16:21:
> Hallo Semmel,
>
> tut mir leid, aber mir ist das Beispiel nicht so richtig klar. Das 
> geht mir auch oft so mit meinen eigenen Anfragen.
> Mach doch eine Datei und lege sie irgendwo ab, dann gib uns den Link.
>
> Ich habe bei Formeln mit Problemen das immer so gemacht, dass ich 
> jeden einzelnen Item in ein Feld geschrieben habe, also immer weiter 
> die Formel zerlegt, bis ich den Fehler gefunden habe.
>
> Horst
>
> Am 11.11.2015 um 13:58 schrieb Semmel:
>> Fehlerabfrage in CALC:
>>
>> Ist eine „ODER“ Verknüpfung in Verbindung mit „ISTFEHLER“ nicht 
>> möglich oder wo liegt mein Bock?
>>
>> Gegeben sind zwei Tabellenblätter. Im ersten befindet sich eine 
>> Übersichtstabelle, in der verschiedene Jahre waagerecht (Zeile 4) und 
>> die Monate senkrecht (Spalte 1, ab Zeile 4) eingetragen sind. Über 
>> diese Zuordnung von Monat und Jahr suche ich nun im Tabellenblatt 2 
>> („Daten“) nach den entsprechenden Werten.
>>
>> Weshalb aber gibt mir die folgende Formel ein #NV aus, wenn das 
>> entsprechende Datum nicht gefunden wird, *obwohl* ich das mit einem 
>> „ISTFEHLER“ versucht habe abzufangen?
>>
>> =WENN(ODER(ISTFEHLER(SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0));SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;1)<1);"

>> ";SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0))
>>
>>
>> „Ziehe“ ich die Formel auseinander und frage mit WENN (*ohne* ein 
>> „ODER“) ab, ob
>> a) ein Fehler besteht 
>> [=WENN(ISTFEHLER(SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0));" 
>> ";SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0))], dann 
>> klappt das und die Zelle bleibt wie gewünscht leer und
>>
>> b) der gesuchte Wert kleiner 1 ist 
>> [=WENN(SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;1)<1);" 
>> ";SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0))], dann 
>> klappt auch das für sich genommen, wenn das gesuchte Datum besteht. 
>> Aber „es geht“ in dem Augenblick nicht mehr (Ergebnis: #NV), wenn das 
>> Datum erst gar nicht gefunden wird (was mir in dieser entzerrten 
>> Konstellation auch klar ist).
>>
>> Weshalb aber kann ich das mit der eingangs beschriebenen „=WENN(ODER 
>> ...“ -Abfrage nicht abfangen und erhalte (bei nicht gefundenem Datum) 
>> immer ein #NV?
>> Wo liegt mein Fehler?
>>
>> Liebe Grüße, Peter.
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message