openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wolfgang Jäth <jawo.ml.hams...@arcor.de>
Subject Re: Differenzen von Werten in Abhängigkeit vom Datum
Date Sun, 11 Oct 2015 07:40:28 GMT
Am 10.10.2015 um 18:36 schrieb Semmel:
> 
> ich habe im zweiten Tabellenblatt verschiedene Daten, die einem Datum 
> zugeordnet sind (Spalte A das Datum von 1999 bis 2015 und weiter und in 
> Spalte B den dazugehörenden Wert). In der zur Verfügung gestellten 
> Beispieldatei (Link siehe weiter unter) sind bisher nur Werte vom 
> 31.12.1999 bis zum Sommer 2000 vorhanden, die aber später in gleicher 
> Form wie bereits vorhanden ergänzt werden.
> 
> Im ersten Tabellenblatt möchte ich nun eine Auswertung der verschiedenen 
> Monate des jeweiligen Jahres (in Spalte B, C, D ... befinden sich die 
> Jahre und in Zeile 4 bis 15 die Monate).
> 
> Im Ergebnis möchte ich in der Tabelle1 die Werte ermitteln, um wie viel 
> Prozent sich der Wert am Monatsende gegenüber dem Ende des Vormonats 
> verändert hat, wobei "Monatsende" nicht dem tatsächlichen Monatsende 
> entspricht, sondern dem zuletzt vorhandenen Wert des jeweiligen Monats 
> in dem Jahr - und das kann mal der 27., aber auch der 23. Tag des Monats 
> sein.
> Mit <sverweis> komme ich aber immer nur auf die erste Angabe in dem 
> betreffenden Monat (aus Tabelle2) und komme schon allein deshalb nicht 
> weiter, weil ich es nicht schaffe, mir den Wert vom "Monatsletzten" 
> herauszusuchen.
> 
> Unter dem Link 
> http://www.file-upload.net/download-10964548/DifferenzenvonWerten_V1.1-01.ods.html 
> kann das Tabellendokument heruntergeladen werden und ich hoffe, dass ich 
> mich klar genug ausgedrückt habe.
> 
> Kann jemand helfen?

Das Hauptproblem ist IMHO, die Anfangs- bzs. Enddaten jedes Monats zu
ermitteln. Ich würde hier mit 3 Hilfsspalten arbeiten, C, D und E.

Spalte C schleift den Endwert des jeweiligen Vormonats nach unten, in
Spalte D wird das Datum des Monatsanfangs berechnet (Du brauchst ein
identifizierbares Datum), und in Spalte E der der jeweilige
Differenzbetrag zum Vormonat.

In die Zellen C4 - E4 trägst Du folgende Formeln ein:

C4	=WENN(UND(C3<>"";MONAT(A4)=MONAT(A5)); C3; B4)
D4	=WENN(E4=""; ""; A4-TAG(A4-1))
E4	=WENN(MONAT(A4)=MONAT(A5); ""; C4-C3)

Diese drei Zellen markierst Du und kopierst sie in alle Zeilen der
Tabelle. Wie Du siehst, werden in den Spalten D und E nur beim jeweils
Letzten eines Monats überhaupt noch Werte dargestellt. Diese entsprechen
den Werten Deiner Übersichtstabelle, die Du dann mit

=SVERWEIS(DATUM(B$4;ZEILE()-4;1);Tabelle2.D4:E28;2;0)

dorthin übernehmen kannst (evtl. noch die Fehler mit nem WENN ausblenden).

Wolfgang
-- 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message